Operation 7 (shooter) unter Ubuntu 12.04 installieren

...komplette Frage anzeigen

1 Antwort

Das Programm läd diese Dateien: p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden

Es müßte aber /usr/lib/x86_64-linux-gnu/pkcs11 heißen. Dort ist die Datei zu finden. Wie kann ich den Pfad verändern?

PhotonX 28.06.2014, 19:39

Einfach den Pfad zu verändern dürfte nicht helfen, du brauchst die 32bit-Version der Bibliothek. Versuche es mal mit

sudo apt-get install libp11-kit-gnome-keyring:i386

Siehe auch https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/859600

0
roffermann 28.06.2014, 22:10
@PhotonX

Dann kommt :

sudo apt-get install libp11-kit-gnome-keyring:i386

Paketlisten werden gelesen... Fertig

Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig

E: Paket libp11-kit-gnome-keyring:i386 kann nicht gefunden werden

0
PhotonX 28.06.2014, 22:23
@roffermann

Ich sehe gerade, du nutzt noch 12.04, leider ist der Bug für diese Version nicht behoben. Ich fürchte, hier gibt es nur noch drei Möglichkeiten:

  1. Warten auf einen Fix.
  2. Update auf z.B. 14.04.
  3. Irgendwas an der Paketverwaltung vorbei zusammenschustern, dürfte aber ziemlich kompliziert werden.
0
roffermann 28.06.2014, 22:32
@PhotonX

Warten auf einen Fix. Was heißt das? Das Ubuntu irgentwann eine solche Datei zu Verfügung stellt?

0
PhotonX 28.06.2014, 22:36
@roffermann

Ja, genau. Das kann aber länger dauern, bei dem Bug hat sich, wie du an den Kommentaren sehen kannst, seit einem halben Jahr nichts mehr getan. Ich würde in deiner Situation die zweite Möglichkeit empfehlen, 12.04 ist wirklich nicht mehr brandaktuell. :)

0
roffermann 28.06.2014, 22:41
@PhotonX

Ne danke, so wichtig ist das Spiel nicht, welches diese Dateien benötigt. Ich komme ganz gut mit 12.04 klar, in nächster Zeit möchte ich dabei bleiben. Aber Danke

0
LemyDanger57 28.06.2014, 23:38
@roffermann
Ich komme ganz gut mit 12.04 klar,

Meinst Du wirklich, 14.04 wäre entscheidend anders?

0

Was möchtest Du wissen?