OpenOffice sverweis und wenn-funktion?

...komplette Frage anzeigen

2 Antworten

Hallo bieps,

wieviel Vorgänge, also Rechnungseingänge möchtest du denn auf ein Mal listen?

Um bei deinem Beispiel zu bleiben:

  1. Die Zellen A5-A8 formatierst du "000"; dann brauchst du in das Suchfeld bei 1- oder 2- stelligen Kunden-Nummern nicht immer 3-stellig einzugeben.
  2. In F4 gibst du folgende Feldformel ein : =SVERWEIS($E4;$A$3:$B$8;2)
    • in F5 entsprechend : =SVERWEIS($E5;$A$3:$B$8;2)
    • usw. bis F8

Wenn du die Formel in F4 nach obrigen Muster erstellt hast, kannst du die fertige Formel auch nach unter kopieren. Aber vorher die Datenbereiche in der Feldformel (hier $A$3:$B$8) noch deinem tatsächlichen Datenbereich anpassen. Dann sparst du dir unnötige Tipperei.

Der Datenbereich muß immer nach Kunden-Nr sortiert sein!

Viel Erfolg bei der Realisierung.

1
@Yorgos

ich danke dir vielmals... hat endlich geklappt und hab noch ne wenn-funktion davor gemacht, weil es sonst immer #NV angezeigt hat, wenn nix drin steht in der zelle davor...

grandios :)

0
@bieps

Freut mich, dass dir die Lösung gefällt. Danke für dein Sternchen!

1
@Yorgos

neues Problem... :(

das ist meine Formel : =WENN(G17="";"";SVERWEIS(G17;$S$1:$T$500;2))

Mein Problem ist, wenn ich eine Ziffer von 170 bis 202 eingebe, zeigt es mir immer wieder die selbe Firma an die die Nr. 202 hat. Bin verwirrt, weil es bei den anderen Nr. super funktioniert, aber eben nur bei diesen nicht... gibts da ne möglichkeit, das zu beheben???

0
@bieps

Ergänze mal deine Formel(n) :

=WENN(G17="";"";SVERWEIS(G17;$S$1:$T$500;2;0))

Dann wird die Matrix auch unsortiert durchsucht.

Wenn du noch mal 'ne Frage haben solltest, schick mir bitte eine Nachricht mit einem Hinweis. War jetzt eher Zufall, dass ich hier in den alten Beständen deine Frage gefunden habe.

Gruß, Yorgos

1

Wir atmen ruhig und ohne Angst...

Arbeitest Du in Openoffice Calc und hier mit einer Datenquelle, in der u.a. Kundenummer und Kundenname stehen... z.B. ein Zugriff auf die Kundentabelle des Lexware, zu dem Du vor einigen Tagen eine Frage gestellt hast?

Wo genau möchtest Du dann die (Kunden-?)Nummer eingeben, neben der der Name angezeigt werden soll, und woher soll er den Namen beziehen? Aus einer anderen Calc (Excel-) Tabelle, direkt aus einer Datenbank oder geht es um Openoffice Base?

Vielleicht noch mal einen neuen Frage-Anlauf....

ganz schön viele Fragen :) Also ich arbeite in Openoffice Calc und dort ist auch die Datenbank mit den Unternehmer und den Unternehmernummern erfasst. Ich arbeite hierzu nicht mit Lexware, sondern komplett in Openoffice Calc.

die Unternehmernr. möchte ich im Rechnungseingang (auch Openoffice Calc) eintragen. In dieser Datei habe ich auch die Unternehmen mit ihren Nummern gespeichert (in einem extra Tabellenblatt). Wie schon gesagt, die Wenn-Funktion wäre perfekt, aber wir haben über 200 Unternehmen. Jetzt suche ich nach einer anderen Möglichkeit.

0

Was möchtest Du wissen?