OpenOffice CalcExperte benötigt?

...komplette Frage anzeigen

2 Antworten

=Summewenn(A:A;"A";D:D)/Zählenwenn(A:A;"A")

Vllt gibt es sogar MittelwertWenn, schau mal nach.

Die neuesten Versionen von LO akzeptieren die Schreibweise A:A, bei älteren musst Du zB A$1:A$999 schreiben, ebenso in OO (ich würde Dir ohnehin LibreOffice empfehlen, das wird besser gewartet, ist ja ebenfalls kostenlos).

DeeDee07 14.08.2016, 08:57

Ja, es gibt auch MITTELWERTWENN(S).
Die Formel wäre dann

=MITTELWERTWENN(A:A;"A";D:D)

Bzw. in OO ohne ganze Spalten:

=MITTELWERTWENN(A1:A999;"A";D1:D999)


1
werdas34 14.08.2016, 19:28
@DeeDee07

Super. Hat funktioniert. Das Problem ist, wenn ich noch keine Einträge für das Produkt habe, dann zeigt er mir logischerweise #DIV/0! an. Ich hätte aber gerne das "0" in der Zelle steht.

Hätte nun folgendes probiert:
=Wenn(D1:D999>0;MITTELWERTWENN(A1:A999;"A";D1:D999);0))

Er zeigt mir aber nur #WERT! an und ich weiß nicht warum. 
Könnt ihr mir da noch kurz helfen?

1
Iamiam 15.08.2016, 01:29
@werdas34

Probiers mal mit =Wennfehler(Formel;0)

[ohne Gewähr, so tief steck ich in OO/LO nicht drin]

1
DeeDee07 17.08.2016, 15:59
@werdas34

Iamiams Lösung sollte funktionieren. Ansonsten könntest du deine Formel so ergänzen:

=Wenn(SUMME(D1:D999)>0;MITTELWERTWENN(A1:A999;"A";D1:D999);0)

Dann sollte sie auch funktionieren (ungetestet).

1

Du kannst auch den Quotienten der (Quasi-Matrix-)Formeln

=SUMMENPRODUKT((A2:A999="A")*D2:D999)/SUMMENPRODUKT((A2:A999="A")*1)

verwenden. Diese Formel kann manchmel sinnvoll sein, hier ist sie länger als Summewenn/Zählenwenn oder gar Mittelwertwenn

Die beiden Bereiche müssen aber exakt die gleiche Zellenzahl umfassen und der Bereich D2:D999 darf nur Zahlen (oder leere Zellen) enthalten!

(nur wg des Prinzips erwähnt: auch ein Datum wäre eine Zahl, aber das macht ja hier keinen Sinn)

Die Einführung von A:A ist offensichtlich noch nicht fertig, in obiger Formel funktioniert das noch nicht!

DeeDee07 14.08.2016, 19:05

DH!

Bei mir (LO-Version 5.0.5.2) funktioniert deine Summenprodukt-Formel auch mit A:A ganz gut.

Dabei habe ich zufällig entdeckt, dass LO bei der Prüfung von Texten Case-sensitiv ist, im Gegensatz zu Excel.

Formel: ="A"="a"
Excel: WAHR
LO: FALSCH

1
Iamiam 15.08.2016, 01:27
@DeeDee07

A:A: meine LO 5.1.3.2. macht da mit bei Mittelwertwenn, nicht aber bei Summenprodukt!

a=A: ja in LO FALSCH, aber Mittelwertwenn(...;"a";...) wird gezählt, auch wenn in Auszuwertender Zelle "A" steht! Ist wohl noch nicht ganz ausgereift? Oder ist es eine Frage von Einstellungen?

1

Was möchtest Du wissen?