Nochmal an DeeDee07. Bild ist im Anhang. Es geht um Spalte 3, die quasi immer sofort entsteht ohne weitere Eingaben, Filter setzen, Sortieren,... Geht das?

...komplette Frage anzeigen Excel-Snapshot - (Excel, Office)

2 Antworten

das hat deedee doch beantwortet - es ist die genannte Matrixformel. Einfacher geht das mit Formeln nicht. Excel ist nicht darauf ausgelegt Ergebnislisten zu erzeugen. Filtern / Sortieren - alles kein Problem, aber Listen eben nicht.

Alternativ kannst Du überlegen, ob Du die Liste als Pivottabelle erzeugen willst. Die Spalte B hierbei als Berichtsfilter

 - (Excel, Office)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Hackameista
20.04.2017, 21:36

Wenn ich die Matrixformel in Spalte C kopiere erscheint da gar nix außer der Formel selbst. Ich bin kein Excel-Experte und habe noch nie von Matrixformeln (außer in meinem Mathestudium) gehört.

0
Kommentar von Hackameista
20.04.2017, 21:40

Und Filter hab ich auch noch nie gesetzt. Es tut mir ja leid. Aber nett, dass du nicht borniert angeklickt hast, sondern nur blöd und frech.

0

Tag!

Du könntest dir auch 2 Hilfsspalten machen und diese später verstecken.

Rechtsklick auf Spalte "A" Spalte Einfügen - Das machst du 2x sodass deine Werte nicht mehr in Spalte a, sondern in Spalte C stehen.

In A2 gibst du jetzt ein:

=WENN(C2="Ja";1;"")

Die Formel ziehst du runter bis Ax (so lang du willst)

In B2 schreibst du jetzt diese Formel:

=ZÄHLENWENN(A2:A2;"1")

Diese Formel ziehst du jetzt auch runter!

Jetzt kannst du in F2 schreiben

=WENN(ISTNV(SVERWEIS(1;$B$2:$C$20000;2;0));"";SVERWEIS(1;$B$2:$C$20000;2;0)

So kriegst du in F2 immer den ersten Wert der mit "Ja" gekennzeichnet wurde.

Um das ganze noch zu automatisieren, sodass du deine Suchkriterien nicht ändern musst, kannst du dir nochmals eine Hilfsspalte erstellen.

Die Hilfsspalte befüllst du mit Zahlen von 1 bis 20000 oder eben so viele wie du willst.

Ich nem jetzt als Beispiel mal die Spalte G

G2:1
G3:2
G4:3
G5:...

Die Zeichenkette kannst du auch runter ziehen!

Jetzt ändert du in der SVERWEIS()-Formel einfach das Suchkriterium auf die Zelle G2:

=WENN(ISTNV(SVERWEIS(G2;$B$2:$C$20000;2;0));"";SVERWEIS(1;$B$2:$C$20000;2;0)

Die Formeln sind somit alle Kopierbar und passen sich dem Tabellenblatt an.

Einmal Aufwand danach nie wieder!

Liebe Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von iMPerFekTioN
21.04.2017, 09:26

Am besten wäre es die ZÄHLENWENN()-Formel so zu schreiben:

=WENN(A2="";"";ZÄHLENWENN($A$2:A2;"1"))

Dann hast du keine doppelten Zahlen....

0

Was möchtest Du wissen?