Name bis LEER bzw. KOMMA wiedergeben

...komplette Frage anzeigen

1 Antwort

Probiers mal mit

=LINKS(A5;VERWEIS(9^9;MIN(WENN(ISTFEHLER(FINDEN(",";A5;1));LÄNGE(A5);FINDEN(",";A5;1))-1;WENN(ISTFEHLER(FINDEN(" ";A5;1));LÄNGE(A5);FINDEN(" ";A5;1))-1)))

etwas umständlich, sollte aber funktionieren. Liefert nur bei leeren Zellen Fehler. zu beheben mit weiterer Verkomplizierung:

=Wenn(Länge(A5)<1;"leer";"obige Formel")

Vllt weiß jemand was einfacheres?

das Verweis(9^9; samt schließender Klammer ) kannst Du ersatzlos streichen ! =>

=wenn(länge(A5)<1;"leer";LINKS(A5;MIN(WENN(ISTFEHLER(FINDEN(",";A5;1));LÄNGE(A5);FINDEN(",";A5;1))-1;WENN(ISTFEHLER(FINDEN(" ";A5;1));LÄNGE(A5);FINDEN(" ";A5;1))-1)))

1
@Iamiam

Danke erstmal, aber klappt leider nicht :-(

Bekomme nur FALSCH ausgegeben...

0
@Sven8219

merkwürdig, selbst wenn ich die Formel (die im Kommentar) hier rauskopiere und in eine Zelle einsetze, liefert sie die erwarteten Ergebnisse:

Famname, Vorname =>Famname
Famname,Vorname =>Famname
Famname Vorname =>Famname
FamnameVorname =>FamnameVornam
123456 => 12345
123,456 =>123
leere Zelle => leer
Ergebniszelle als Text formatiert: Obiger Formel-Bandwurm

Falsch bekomme ich durch nichts, was mir einfällt, ausser, wenn in der Zelle schon ein Fehler steht, zB #DIV/0! (erscheint komplett, also nicht um 1 Zeichen verkürzt, weil sich der Fehler als solcher fortpflanzt und nicht als Text!) eine scheinbar leere Zelle erhalte ich, wenn führende Leerzeichen oder Kommata auftreten:

,Famname,Vormame => nichts Sichtbares

FALSCH bekomme ich nur, wenn ich die Formel so verändere:

=WENN(LÄNGE(A5)<1;"leer";LINKS(A5;MIN(WENN(ISTFEHLER(FINDEN(",";A5;1));LÄNGE(A5);FINDEN(",";A5;1))-1;WENN(ISTFEHLER(FINDEN(" ";A5;1));LÄNGE(A5);FINDEN(" ";A5;1))-1)))=WAHR (oder FALSCH, beides liefert FALSCH)
Gibt es vllt (inzwischen?) die mir nicht bekannte Möglichkeit, eine Zelle als Booleschen Wahrheitswert zu formatieren? Dann wäre das vorstellbar.

1
@Iamiam

jetzt hab ich auf Basis Deiner Formel nochmal verändert und auch gekürzt, dürfte die bessere Lösung sein, zumindest kürzer:

=LINKS(A5;MIN(WENNFEHLER(FINDEN(",";A5);999);WENNFEHLER(FINDEN(" ";A5);999))-1)

geht ab Vs. xl2007. Vorher muss man mit =istfehler arbeiten und das Argument wiederholen, ist aber immer noch kürzer als mein obiger Ansatz!

1
@Iamiam

mit ISTFEHLER(bis xl2003 notwendig) hier nochmal ausgeführt:

=LINKS(A5;MIN(WENN(ISTFEHLER(FINDEN(",";A5));999;FINDEN(",";A5));WENN(ISTFEHLER(FINDEN(" ";A5));999;FINDEN(" ";A5)))-1)

1

Was möchtest Du wissen?