Mustertabelle mit andere Tabelle in einer Spalte vergleichen?

...komplette Frage anzeigen

2 Antworten

  1. Du kannst nicht in derselben Zelle, wo schon was steht, eine Formel setzen, die diesen Text mit was anderem vergleicht.
  2. Es geht auch nicht, so einem Text zu entnehmen, WAS anders ist, sondern nur, dass irgendetwas etwas anders ist. Was Du kannst, ist Anfänge definierter oder definierbarer Länge zu vergleichen, ebenso Ende oder Teile, aber nicht alles gleichzeitig. Obendrein verschiebt sich durch "das anders" meist die Position der folgenden Zeichen, so dass auch ein Zeichen-für-Zeichen-Vergleich nicht geht. Du kannst allerdings einzelne Zeichen -sowohl als definierter Text oder auch DEFINIERTER Position UND Länge durch was anderes ersetzen - aber xl muss immer genau "gesagt" kriegen, was denn jetzt.

Ninombre hat ja schon einen brauchbaren Ansatz geliefert.

Wenn du was anderes brauchst, musst Du uns sagen, ob in Spalte B Zahlen oder Texte stehen (es gibt auch Zahlen als Texte: Der Unterschied ist, dass Zahlen intern im Dualsystem der Zahlen gespeichert werden, Ziffernfolgen dagegen mit dem Code der Einzelziffern, zB ist die Ziffer 0 =048, die Ziffer 1 = 049

  • Die Zahl 10 ist also im Dualsystem 1*2^3+0*2^2+1*2^1+0*2^0, also 1010
  • im Textsystem(8bit = 256 mögliche Zeichen=ASCII-Code) ist die 010 dagegen
  • 0*2^7+0*2^6+1*2^5+1*2^4+0+0+0+0*2^0; 0*2^7+0*2^6+1*2^5+1*2^4+0+0+0+1*2^0 ;0*2^7+0*2^6+1*2^5+1*2^4+0+0+0+0*2^0
  • => 00110000;00110001;00110000;

die beiden müssen also ganz klar unterschieden werden, was xl durch die Gänsefüßchen für Ziffernfolgen bewerkstelligt

Nun wollte ich aber nicht von Deinem Thema ablenken:

Willst Du den alten Zelleintrag komplett durch den neuen (oder umgekehrt?) oder willst Du beide Einträge nebeneinander dargestellt haben (geht auch in der gleichen Zelle in der Bearbeitungszeile, musst Du nur sagen, was du willst).

Wenn man glaubt, durch Lebenserfahrung hätte man genau denken gelernt, belehrt und xl eines anderen: es erfordert eine ganz andere Art des genau analysierens und Beschreibens.

(ich entnehme Deinem Alias-Namen, dass Du älter bist und glaube als längst-Rentner Dir das sagen zu dürfen)

Antwort bewerten Vielen Dank für Deine Bewertung

Die Frage ist ehrlich gesagt etwas arg knapp und verworren formuliert.

Was genau wird abgeglichen?
- Soll der Werte irgendwo in Spalte B auftauchen? Das prüft man mit =zählenwenn(...)>0.

- Es soll dann in dieser Zeile jeweils der Wert der Spalte AB verglichen werden?
=sverweis("xzy";Tabelle2!B1:AB1000;27;falsch) o.ä. liefert den Eintrag aus Tabelle2

=WENN(ZÄHLENWENN(Tabelle1!B1:B100;"Hugo")=0;"nicht vorhanden";WENN(SVERWEIS("Hugo";Tabelle1!B1:AB1000;27;FALSCH)=AB1;"gleich";"nicht gleich"))

Ob das passt, kann ich ohne nähere Information nicht sagen.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?