MS ExceL: Zeichen wegschneiden

...komplette Frage anzeigen

3 Antworten

Hallo Björn,
wenn du von einem Text etwas abschneiden möchtest,
kannst du das z.B. mit der Excel-Funktion =LINKS(Text;Anzahl_Zeichen) machen.
Also, wenn in A1 1+ steht, dann schreib in B1 folgende Funktion rein:
=LINKS(A1;1)*1
Die Multiplikation mit 1 macht aus dem Text eine Zahl.
Gruß Distel

Bjoern96 18.02.2010, 20:54

Danke, ich hab es versucht, hilft aber auch nicht richtig, weil excel dann bei einer "1" die ganze Zahl löscht. Mit einer "wenn-funktion" ( =wenn(A1 <>1;LINKS(A1;1)*1) ) funktioniert das ja auch nicht, weil jeder sechs verschiedene Noten haben kann.

0
Distel35 18.02.2010, 21:07
@Bjoern96

Ich hab Excel 2003 und bei mir tritt dieser Fehler bei 1 nicht auf.
>weil excel dann bei einer "1" die ganze Zahl löscht.

0
Bjoern96 18.02.2010, 21:09
@Distel35

Nein, ich habe nur gedacht, dass excel die Zeichen irgendwie löscht und nicht wiedergibt. Ich habe das nur falsch verstanden. Alles funktioniert jetzt... DANKE!!!

0

Ich versuche erst einmal deine Frage soweit wie möglich zu verstehen und zu beantworten.

"Außerdem soll sie den Notendurchschnitt anzeigen und anzeigen, wie viel Noten es von einer Note (1-6) gibt. Alles außer das letzte habe ich geschafft." Gut, wenden wir uns diesem Problem zu: Mit der Formel: Zählenwenn(Bereich;Note). So erhälst du die Anzahl jeder Note.

Den Rest habe ich leider nicht verstanden.:-(

Bjoern96 18.02.2010, 20:50

Ich habe das ja auch schonmal mit "zählenwenn..." probiert, doch es gibt ja nicht nur eine Möglichkeit (1) sondern drei (1-, 1, 1+). Die bekommt man ja nicht alle in eine zählenwenn formel rein.

0

na dann vielleicht so:
schreibe in Zelle A10:
=ZÄHLENWENN(A1:A9;1)+ZÄHLENWENN(A1:A9;"1+")+ZÄHLENWENN(A1:A9;"1-")
nicht schön, aber fuktioniert!

Bjoern96 18.02.2010, 21:15

Die obige Antwort von dir funktioniert. Danke!

0

Was möchtest Du wissen?