Moien, ich benötige für folgenden Berechnung eine Excel-Formel: Es soll 10% von einem €-Betrag abgezogen werden, aber mindestens 5,00 € und höchstens 10,00 €?

... komplette Frage anzeigen

4 Antworten

das geht hiermit

=A1-MAX(5;MIN(A1/10;10))
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
28.01.2016, 18:32

Die erhoffte elegantere Lösung 

0

=WENN(A1*10%<5;A1-5;WENN(A1*10%>10;A1-10;A1-A1*10%))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Weaselz
28.01.2016, 17:37

Funktioniert wunderbar! Eine Ergänzung noch: Wie muss die Formel aussehen, wenn ich den Abzugsbetrag zwischen 5,00 bis 10,00 € in einer separaten Zeile sehen möchte.

Also

1. Feld: Rechnungsbetrag

2. Feld: Formel, um auszurechnen, welcher Betrag zwischen 5,00 bis 10,00 € abgezogen wird (Ergebnis zw. 5 bis 10)

3. Feld: Rechnungsbetrag - Ergebnis aus dem 2. Feld

0

=WENN(A1*0,1<5;A1-5;WENN(A1*0,1>10;A1-10;A1-A1*0,1))

vielleicht geht es auch eleganter, aber nicht in meinem Kopf z.Zt ;-)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Koellemann
28.01.2016, 17:02

Muesste es nicht ...;A1-A1*0,1;... heissen? Sonst zieht er ja 5 ab und nicht 10%

0

Nehmen wir mal dein Betrag steht in der Zelle A1

Dann schreibst du in B1 rein: =A1*0,1

In Zelle C1 schreibst du: =WENN(10<B1>5;A1-B1)

Das sollte klappen, lass mich wissen wenn nicht :)

LG

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
28.01.2016, 17:49

das kann nicht funktionieren.
Mal abgesehen davon, das da keine Anweisung gibt, was zu tun ist, wenn die 10% nicht zwischen 5-10 Euro liegen. Kann Excel keine mathematischen Wertebereiche der art a<b<c auswerten.

Excel überprüft die erste bedingung "a<b" und erhält einen Textwert (wahr/falsch). Danach vergleicht es diesen Textwert mit c
Wobei Texte IMMER als größter als Zahlen gewertet werden.

Damit ist dein Syntax für Excel in keiner Weise geeignet.

2

Was möchtest Du wissen?