Minecraft server (spigot) will plugins nicht mehr annehmen?

...komplette Frage anzeigen

4 Antworten

Welche Java Version verwendet dein Server, der fehler trit meistens auf wenn Java zu neu doer zu alt für die Plugins sind. Falls du Java 7 oder OpenJDk verwendest installiere Java 8

BinNurDerJordan 06.06.2017, 23:01

Also meinst du, dass es vlt an der version liegen könnte?

0
BinNurDerJordan 06.06.2017, 23:02

also der root ist auf java 7

0
BinNurDerJordan 06.06.2017, 23:03

kennst du den genauen befehl zum installieren von java 8 auf root (linux debian)?

0
TopicsLP 06.06.2017, 23:15
@BinNurDerJordan

Hiermit sollte java 8_131 ganz schnell installiert sein:

wget http://javadl.oracle.com/webapps/download/AutoDL?BundleId=220305_d54c1d3a095b4ff2b6607d096fa80163
mv AutoDL?BundleId=220305_d54c1d3a095b4ff2b6607d096fa80163 jre-8u131-linux-x64.tar.gz
tar -xvf jre-8u131-linux-x64.tar.gz
mkdir /opt/Oracle_Java
cp -R jre1.8.0_131 /opt/Oracle_Java/jre1.8.0_131
update-alternatives --install "/usr/bin/java" "java" "/opt/Oracle_Java/jre1.8.0_131/bin/java" 1
update-alternatives --install "/usr/bin/javaws" "javaws" "/opt/Oracle_Java/jre1.8.0_131/bin/javaws" 1
update-alternatives --set "java" "/opt/Oracle_Java/jre1.8.0_131/bin/java"
update-alternatives --set "javaws" "/opt/Oracle_Java/jre1.8.0_131/bin/javaws"
0

Du verwendest Java 7 für die Plugins brauchst du allerdings Java 8

BinNurDerJordan 06.06.2017, 23:27

aber die plugins die ich drauf habe (13 plugins) funktionieren meinst du damit, dass diese plugins j7 sind ? und die anderen j8? Wenn ja dann mache ich ein update für den root server, kennst du den befehl dafür? Den anfang kenne ich, der ist Apt-get install...

0

Du musst Java 8 installieren. Laut den von dir geposteten Logs hast du Java 7 installiert und die von dir verwendeten Plugins funktionieren nur mit Java 8.

Ishidres 07.06.2017, 10:37

Tipp: Poste mal den Inhalt von 'java -version'

0
BinNurDerJordan 07.06.2017, 13:36

kennst du denn den befehl? weil ich ihn nicht kenne

0
BinNurDerJordan 07.06.2017, 13:38

root@vps:~# java -version java version "1.7.0_121" OpenJDK Runtime Environment (IcedTea 2.6.8) (7u121-2.6.8-2~deb8u1) OpenJDK 64-Bit Server VM (build 24.121-b00, mixed mode)

0
Ishidres 07.06.2017, 19:54

Jo, du hast Java 7 installiert. Moment ich such dir das richtige Tutorial für die Installation von Java 8 raus, die ich verwendet habe und die auch super klappt!

0

Warning, your max perm gen size is not set or less than 128mb. It is recommended you restart Java with the following argument: -XX:MaxPermSize=128M
Please see http://www.spigotmc.org/wiki/changing-permgen-size/ for more details and more in-depth instructions.
Loading libraries, please wait...
[15:54:31 INFO]: Starting minecraft server version 1.8.8
[15:54:31 INFO]: Loading properties
[15:54:32 INFO]: Default game type: SURVIVAL
[15:54:32 INFO]: This server is running CraftBukkit version git-Spigot-db6de12-18fbb24 (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
[15:54:32 INFO]: Server Ping Player Sample Count: 12
[15:54:32 INFO]: Using 4 threads for Netty based IO
[15:54:32 INFO]: Debug logging is disabled
[15:54:32 INFO]: Generating keypair
[15:54:33 INFO]: Starting Minecraft server on *:25565
[15:54:33 INFO]: Using epoll channel type
[15:54:35 INFO]: Set PluginClassLoader as parallel capable
[15:54:35 ERROR]: Could not load 'plugins/AdminTools.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: net/goobsygames/admintools/main/Main : Unsupported major.minor version 52.0
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at java.lang.Thread.run(Thread.java:745) [?:1.7.0_121]
Caused by: java.lang.UnsupportedClassVersionError: net/goobsygames/admintools/main/Main : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_121]
at java.lang.ClassLoader.defineClass(ClassLoader.java:803) ~[?:1.7.0_121]
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_121]
at java.net.URLClassLoader.defineClass(URLClassLoader.java:442) ~[?:1.7.0_121]
at java.net.URLClassLoader.access$100(URLClassLoader.java:64) ~[?:1.7.0_121]
at java.net.URLClassLoader$1.run(URLClassLoader.java:354) ~[?:1.7.0_121] at java.net.URLClassLoader$1.run(URLClassLoader.java:348) ~[?:1.7.0_121] at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_121]
at java.net.URLClassLoader.findClass(URLClassLoader.java:347) ~[?:1.7.0_121]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_121]
at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_121]
at java.lang.Class.forName0(Native Method) ~[?:1.7.0_121]
at java.lang.Class.forName(Class.java:278) ~[?:1.7.0_121]
at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
... 6 more
[15:54:35 INFO]: [INFO][NoCheatPlus] Tue Jun 06 15:54:35 EDT 2017
[15:54:35 INFO]: Player instances are stored for efficiency.
[15:54:36 INFO]: [Citizens] Loading Citizens v2.0.16-SNAPSHOT (build 1267)
[15:54:36 INFO]: [MOTDColor] Loading MOTDColor v0.5
[15:54:36 INFO]: [InWartung] Loading InWartung v1.2
[15:54:36 INFO]: [ProtocolLib] Loading ProtocolLib v4.2.0
[15:54:36 WARN]: [ProtocolLib] Detected outdated Java version: Java 7
[15:54:36 WARN]: [ProtocolLib] It is recommended that you update to Java 8 as soon as possible.
[15:54:36 WARN]: [ProtocolLib] Future versions of ProtocolLib many not support Java 7.
[15:54:36 WARN]: [ProtocolLib] Java 8 will allow for much faster reflection performance.
[15:54:36 INFO]: [WorldEdit] Loading WorldEdit v6.1.5;4651611
[15:54:36 INFO]: [PermissionsEx] Loading PermissionsEx v1.23.4
[15:54:36 INFO]: [Multiverse-Core] Loading Multiverse-Core v2.5-b719
[15:54:36 INFO]: [HolographicDisplays] Loading HolographicDisplays v2.2.5
[15:54:36 INFO]: [WorldGuard] Loading WorldGuard v6.1

Was möchtest Du wissen?