Minecraft Server 1.8 mit Craftbukkit, title anzeigen beim joinen?

...komplette Frage anzeigen

4 Antworten

Installier Spigot auf deinem Server und benutz' dann diese Funktion: http://pastebin.com/riWRMVzJ

Also "sendTitle(Player, titel, untertitel);" - zum Beispiel:

"sendTitle(p, "Wilkommen", "auf meinem Server");"

Hab gerade mal Spigot bei mir drauf, und direkt das erste Problem.. Die Rang-Prefixes von PermissionsEX werden nimmer angezeigt :-/ Hast du auch deine Lösung dafür, desweiteren schonmal vielen Dank für deine Lösung

0
@marco19999

Hast du die neuste Version von PermissionsEx auf deinem Server installiert? Eigentlich sollte das noch funktionieren.

0
@marco19999

Komisch, bei mir funktioniert PermissionsEx mit Prefixen und den Titlen reibungslos. Kommt eine Fehlermeldung?

0
@CytoPcSupport

Keine Fehlermeldung.. Weder Ingame, noch in der Konsole. Server.pro zeigt mir die Version 1.23.4 von PEX an.. Ist das die aktuellste?

0
@CytoPcSupport

Wenn ich in EssentialsChat {GROUP} mit vor den Name mache, wird die Gruppe mit angezeigt, aber auch nicht der richtige Prefix, sprich die Farbe usw. passt trotzdem nicht von PEX

0

Diese Methode ist einfach nur schlecht. Wenn man zu dumm ist Reflections zu benutzen, sollte man eine Library verwenden die das tut.

0
@androhecker

Einfach nur schlecht? Was genau ist daran schlecht? Würdest du dich etwas belesen, wie ich es gerade gemacht habe, würdest du wissen, dass seit dem neuesten Essentials-Update die PEX Prefixes nichtmehr unterstützt werden und somit zu ChatEX oder Sonstiges gegriffen werden muss, und das habe ich jetzt gemacht. Jetzt funktioniert alles wieder perfekt wie es soll, mehr will ich nicht. Und wieso sollte ich eine extra Library verweden, wenn ich es auch mit Spigot einfach machen kann? Zudem hat Spigot deutlich mehr Vorteile, was andere auch schon beschrieben haben.

0

Falls es dir nicht aufgefallen ist habe ich den Code auf pastebin oben kritisiert, sowas sollte man nicht verwenden.

0

Und Essentials ist nicht mal mit 1.8 kompatibel...

0
@androhecker

Essentials ist ohne Probleme auf 1.8 kompatibel, merke ich ja selber. Bisher keine Probleme, das einzigste, was nicht kompatibel ist, ist der Chat von Essentials. Und das habe ich jetzt umgangen, fertig.

0

Lesen hilft... http://dev.bukkit.org/bukkit-plugins/essentials/ "There is no official Bukkit for Minecraft 1.8 There is no official Essentials for Minecraft 1.8" Essentials war noch nie gut, wenn du was gutes willst solltest du CommandBook benutzen.

0
@androhecker

Essentials wird eventuell nicht auf 1.8 geupdated, trotzdem funktionieren soweit alle Funktionen auf der 1.8. Für mich ist das hier jetzt jedenfalls abgeschlossen, mein Problem wurde gelöst, alles funktioniert und Ende. Gute Nacht

0

Schicke doch mal die ip würde gerne bauen helfen :D

Spigot und TitleAPI benutzen.

Habe ich durch Spigot dann irgendwelche Vor-/Nachteile? Bzw. sind meine Plugins weiterhin alle kompatibel?

0

Spigot ist ein Patch für Bukkit der alles optimiert, wodurch der Server deutlich schneller ist. Ich frage mich sowieso wo du die Bukkit Jar her hast, Bukkit ist offiziell beendet.

0

Haue Spigot auf deinen Server ist eh besser

Habe ich durch Spigot dann irgendwelche Vor-/Nachteile? Bzw. sind meine Plugins weiterhin alle kompatibel?

0

Teste es doch aus eigentlich JA
+ Du kannst die whitelist Naxhrichten einstellen etc.

0

Was möchtest Du wissen?