Minecraft Plugin lädt nicht mehr?

3 Antworten

Du kompiliert mit Java 9 und führst mit Java 8 aus, das geht nicht. Nimm für Minecraft immer Java 8, die Versionen darüber sind zwar grundsätzlich kompatibel mit MC selbst, aber nicht mit einem Großteil der Plugin-/Modloader.

Das Plugin wurde mit Java 9 exportiert und es wird versucht auf einem Server der mit Java 8 gestartet wurde auszuführen was nicht machbar ist.

  • Java 6 uses major version 50
  • Java 7 uses major version 51
  • Java 8 uses major version 52
  • Java 9 uses major version 53
  • Java 10 uses major version 54
  • Java 11 uses major version 55

Du wirst das Plugin entweder mit Java 8 exportieren müssen, oder den Server mit Java 9 Starten müssen.

Um auf nummer sicher zu gehen deinstalliere JDK 9 und installiere JDK 8

Woher ich das weiß:Hobby – Hin und wieder ein kleines Plugin selber machen

Installiere Java 9 (oder höher), dann läufts.

Woher ich das weiß:Eigene Erfahrung – Ich habe selber lange im PC gearbeitet

habe ich bereits

0
@sky1783

Sorry, genau andersrum. Du musst Java 9 (oder höher) installieren.

0
@sky1783

kann ich java 8 noch behalten (wegen älteren versionen)?

0
@sky1783

Kannst du versuchen, wahrscheinlich wirds ohne Anpassung der Launcher aber dann nicht parallel funktionieren, da die Installation die Windows-Systemvariablen überschreiben wird.

0
@sky1783

Installiere erstmal die neueste Java version und lasse die alte installiert. Eventuell lässt sich die zu nutzende Version dann auch im Java-Control panel einstellen.

0
@ZaoDaDong

kann man denn den server nicht zu java 8 zwingen???

0
@sky1783

Die Fehlermeldung sagt explizit, dass Java 9 oder höher benötigt wird. Die aktuelle Server-Installation setzt also mindestens das vorraus. Möglich ist auch, dass diese Vorraussetzung nur für das spezielle Plugin gilt, weil es mit java9 oder höher geschrieben wurde.

0
@sky1783

dann nutzt du eventuell eine Bibliothek oder andere Abhängigkeit, die nur mit Java9+ läuft.

0
@sky1783

gibt es eigentlich ein gegengift gegen "*** Server will start in 20 seconds ***"

0
@sky1783
gibt es eigentlich ein gegengift gegen "*** Server will start in 20 seconds ***"

Ja, die Server Jar updaten.

0

Was möchtest Du wissen?