Minecraft Plugin compile fehler - wie beheben?

...komplette Frage anzeigen Fehlermeldung - (Minecraft, Plugin, Canary mod) Script - (Minecraft, Plugin, Canary mod)

2 Antworten

Ich vermute das er die Bibliotheken die Canary Mod selbst nutzt nicht finden konnte. Da spielt eine menge Hintergrundwissen mit rein, wie ein Linker funktioniert, etc..

Die einfachste möglichkeit ist aber, meiner Meinung nach, mit einer Entwicklungsumgebung wie Eclipse zu arbeiten. So wie ich das sehe ist JEdit ja nur eine Editor, so wie Notepad++.

Wenn du Eclipse nutzt, kannst du einfach die alle Bibliotheken, die auf Canary basieren mit einbinden. Noch dazu hast du den Vorteil dein Code einfach runter zuschreiben und Eclipse sagt dir im nachhinein welche Bibliotheken du einbinden musst. Außerdem macht dich Eclipse schon wärend der Entwicklung auf Fehler aufmerksam, so das du es nicht extra Kompilieren musst.

Ich habe genau das selbe Problem. Haben die Bibliotheken vielleicht einen neuen Namen bekommen??

@JuicyLuisian

In dem Buch wird beschreiben, dass hier nur einfache .java- Dateien benötigt werden, und Eclipse zu umfangreich für das Buch wäre. Für die paar Zeilen Text reicht sowas ja auch.

Was möchtest Du wissen?