Minecraft Gamemode 1 will nicht ?

...komplette Frage anzeigen

3 Antworten

  1. Hast du irgendwelche Plugins installiert? (Welche?)
  2. Es gibt bei dem Fehler immer eine Java-Fehlermeldung in der Server-Konsole. Poste die mal hier als Kommentar, bitte.

LG Andi

Affenking39 30.06.2017, 15:07

[15:06:43 ERROR]: null
org.bukkit.command.CommandException: Unhandled exception executing command 'gamemode' in plugin Essentials v2.13.1
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[craftbukkit.jar:git-Bukkit-1953f52]
at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140) ~[craftbukkit.jar:git-Bukkit-1953f52]
at org.bukkit.craftbukkit.v1_10_R1.CraftServer.dispatchCommand(CraftServer.java:625) ~[craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.PlayerConnection.handleCommand(PlayerConnection.java:1299) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.PlayerConnection.a(PlayerConnection.java:1159) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.PacketPlayInChat.a(SourceFile:37) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.PacketPlayInChat.a(SourceFile:9) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.PlayerConnectionUtils$1.run(SourceFile:13) [craftbukkit.jar:git-Bukkit-1953f52]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_101]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_101]
at net.minecraft.server.v1_10_R1.SystemUtils.a(SourceFile:45) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.MinecraftServer.D(MinecraftServer.java:690) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.DedicatedServer.D(DedicatedServer.java:360) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.MinecraftServer.C(MinecraftServer.java:646) [craftbukkit.jar:git-Bukkit-1953f52]
at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:550) [craftbukkit.jar:git-Bukkit-1953f52]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]
Caused by: java.lang.NullPointerException
at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:389) ~[?:?]
at com.earth2me.essentials.Essentials.onCommand(Essentials.java:380) ~[?:?]
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[craftbukkit.jar:git-Bukkit-1953f52]
... 15 more

0
01AndiPlayz 30.06.2017, 15:31
@Affenking39
  • Du hast einen Minecraft Bukkit/Spigot 1.10 Server. 
  • Du hast Essentials 2.13.1 installiert.

Essentials in dieser Version ist aus dem Jahr 2014 und nicht ansatzweise kompatibel zur MC 1.10. Wenn du Essentails installierst, werden die Standard-Befehle des Servers (Auch weather oder gamemode) durch Essentials übernommen. Da aber Essentials nicht richtig funktioniert, bekommst du die Fehlermeldung.

Also solltest du Essentials wohl weder deinstallieren oder eine ältere Serverversion verwendet. Das neuste, was Essentials kann ist MC 1.8.

LG Andi

1

Versuch den Befehl mal in der Console auszuprobieren oder den Server neu aufsetzen 

Meine Plugisn:

NoCheatPlus,WorldEdit,TPA,PlotMe,Essentials,

EssentialsProtect, UltraBans,

EssentialsChat, TrollBoss,Setspawn, 

EssentialsSpawn, BanManager, WorldGuard, Multiverse-Core, Bedwars





Was möchtest Du wissen?