!Minecraft! - Fehler bei selbstprogrammierten Plugin. "Class Versions Error"?

 - (Computer, Spiele und Gaming, Minecraft)  - (Computer, Spiele und Gaming, Minecraft)

4 Antworten

Das diese Fehler Meldung auf dem Server erscheint der vermutlich mit Java 8 Patch 191 läuft und das Plugin mit JDK 10 erstellt wurde solltest du dein Java auf dem Server updaten oder die Java Version von Eclipse downgraden.

  • Java 1.2 uses major version 46
  • Java 1.3 uses major version 47
  • Java 1.4 uses major version 48
  • Java 5 uses major version 49
  • Java 6 uses major version 50
  • Java 7 uses major version 51
  • Java 8 uses major version 52
  • Java 9 uses major version 53
  • Java 10 uses major version 54
  • Java 11 uses major version 55
Woher ich das weiß:Hobby – Hin und wieder ein kleines Plugin selber machen

Ausführliche Info und trotzdem übersichtlich.. Gefällt mir! :D

1

Du hast eine zu alte Version des JRE/JDK auf deinem Rechner installiert. Die Klassen wurden mit einer anderen Version kompiliert. Deswegen kann java die nicht lesen. MfG DieGamingMaus

Also muss ich jetzt im Umkehr Schluss was machen? Auf die Eclipse Seite gehen und das neue holen?

0

such bei Google: JDK 8 und installier dir die neueste Version

0
@DIeGamingMaus12

Welches? Java SE Development Kit 8 oder JDK 8 Update Release Notes?

0

auf der offiziellen Java/Oracle seite

0

also bei Google einfach JDK 8 eingeben, dann auf den glaub ich ersten Link klicken, ist glaub ich Oracle.com/wasweißich, dann guck's du unter Sources da dann auf Accept und dann auf den eintrag neben deinem Betriebssystem

0

also unter Sources drunter nicht bei sources

0

Sieht so aus, als würde es diesen Error geben, weil du anscheinend eine zu alte Java Runtime Version hast.

Kleine Frage jetzt auch von mir welche JDK Version ist im Moment aktuell? Und zu welcher Version muss ich Upgraden?

Was möchtest Du wissen?