mehrfache duplikate in excel spalte finden und in anderer mappe ausgeben?

...komplette Frage anzeigen

3 Antworten

die Array-Formel lautet (die geschweiften Klammern gibst du nicht ein, sie werden erzeugt, wenn du die Formel mit Shift-Strg-Enter abschließt):

schreibe in B1:

{=WENN(ZEILE(A1)>SUMME(WENN(A$1:A$99="";0;1/(ZÄHLENWENN(A$1:A$99;A$1:A$99)));-(ZÄHLENWENN(A$1:A$99;A$1:A$99)=1)1);"";INDIREKT("A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("A1:A"&ZEILE($1:$99));A$1:A$99)=1)(ZÄHLENWENN(A$1:A$99;A$1:A$99)>1);ZEILE($1:$99));ZEILE(A1))))}

Diese Formel runterkopieren.

Quelle: http://www.excelformeln.de/formeln.html?welcher=78

Ich denke, dass bringt mich schon ein ganzes Stück weiter :) Weisst du wie man diesen Prozess mittels VBA automatisieren kann? Dann wäre die Lösung zu 100% perfekt.

0
@fantastica1000

In VBA bin ich leider nicht so fit.

Der Witz an der obigen Formel ist aber, dass diese vollautomatisch funktioniert, du brauchst keine Berechnung anzustoßen.

0

Darf denn die Spalte B1:B10 sortiert werden? Wenn ja, dann kannst du alle Werte von Spalte A dorthin kopieren, sortieren und in Spalte h die Formel

"=ZÄHLENWENN($B$10:$B$20;B10)"

herunterziehen.

Ansonsten müsstest du dir mittels VBA einen einfachen Sortieralgorithmus schreiben (z. B. Bubblesort) und die Werte dann in Spalte B schreiben.

die Spalte B kann sortiert oder auch unsortiert bleiben. Wichtig ist nur, dass die Spalte nicht formatiert oder sortiert wird. Und in der Spalte B die Artikelnummer einzeln ausgegeben werden. Also falls in Spalte A 2 x c vorkommt, dann soll er in Spalte B c auflisten und in Spalte H 2, da c zweimal vorkommt. Interessant wäre es, dies mittels VBA zu automatisieren.

0

Für diese Formel braucht die Spalte nicht sortiert zu werden. Und wenn Du =1/Zählenwenn(B:B;B10) schreibst, erhältst Du schon beim ersten Auftreten die Info, wie viele Duplikatte vorhanden sind (Darstellung am besten im Bruchformat, da fällt es auf).

Wenn Du alle Duplikate einer Sorte gleichzeitig sehen willst, empfiehlt sich das Autofilter, Da kannst Du in der Zählenwenn-Spalte auch alle gleich häufigen auf einmal sehen!

0

Hier ein Code von mir:

Option Explicit

Sub Multiple_Inhalte()
Dim I As Double
Dim J As Double
Dim EndZeile As Double
Dim UrWert As String
Dim VergleichsWert As String
Dim EndColl As Double

EndZeile = 100 ' der von dir vorgegebene Wert für Zeilen
EndColl = 1

For I = 1 To EndZeile
    UrWert = Sheets("Tabelle1").Cells(I, 1)
    For J = 1 To EndZeile
        VergleichsWert = Sheets("Tabelle2").Cells(J, 1)
        If UrWert = VergleichsWert Then
            Sheets("Tabelle2").Cells(J, 8) = _
                   Sheets("Tabelle2").Cells(J, 8) + 1
            J = EndZeile
        Else
            If J = EndColl Then
                Sheets("Tabelle2").Cells(EndColl, 1) = UrWert
                Sheets("Tabelle2").Cells(EndColl, 8) = 1
                EndColl = EndColl + 1
                J = EndZeile
            End If
        End If
    Next J
Next I
End Sub

und nochmals als Bild, da der Editor hier immer den Code versaut

Code als Bild - (Excel, VBA)

Was möchtest Du wissen?