Mehrere Felder in Excel vergleichen?

... komplette Frage anzeigen

5 Antworten

Meinst du vielleicht "rot markieren"?

Das geht mit bedingter Formatierung. Hier kannst du auch eine (lange) Formel eingeben; einfacher dürfte aber eine Hilfsspalte sein, in der du Firmenname und Projektname miteinander verkettest (am besten mit einem Trennzeichen dazwischen, damit "Musterfirma " - "GmbH Projekt 1" und "Musterfirma GmbH" - "Projekt1" nicht verwechselt werden können, auch wenn versehentlich zu viele Leerzeichen drin sind).

Falls du tatsächlich sortieren meinst: Unverständlicherweise gibt es (nach meinen Google-Recherche-Ergebnissen) immer noch keine Matrixfunktion SSORTIEREN(Matrix[; Sortierspalte1[; Sortierspalte2[; Sortierspalte3 ...]]]). Da muss man sich mit RANG, VERGLEICH, SVERWEIS u. ä. behelfen. Dazu hat meine Google-Suche folgendes geliefert: http://www.ulrich-rapp.de/stoff/pc/tabkal/#144

Antwort bewerten Vielen Dank für Deine Bewertung

Durch deine AAs und ABs steige ich nicht durch.

Schaff dir notfalls eine Hilfszelle, in der du überprüfst, ob Firma und Projekt übereinstimmen.

Sortieren geht schwer per Formel.

Du kannst aber mit bedingter Formatierung die falschen Zellen einfärben und im Autofilter nach Farbe sortieren.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Magnum1337
27.04.2016, 11:16

Also ich habe eine große excel Tabelle mit Massig Firmen drin und dazu die Projekte jetzt möchte ich prüfen, ob ich doppelte inhalte habe, quasi Die gleiche Firma mit gleichem Projekt / Also 2x Firma 1 mit Projekt 2 , wenn Firma 1 allerdings 2x aufgelistet ist mit Projekt 1 und Projekt 2 dann sollte nichts passieren.

0

genaue formal habe ich jetzt nicht da, sollte aber eine "WENN-Formel" sein.
alles über bedingte Formatierung oder gleich ein Makro.

Antwort bewerten Vielen Dank für Deine Bewertung

Verketten. Verkette Firma mit Projekt und vergleiche diese. Das müsste gehen.

Antwort bewerten Vielen Dank für Deine Bewertung

Beispielliste, Hier soll gesucht werden, Gleiche Firma UND gleiches Projekt, dann farblich markieren

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Funfroc
27.04.2016, 13:09

Hallo,

du hast ja schon geschrieben, dass die Formel von Suboptimierer nun funktioniert, aber du eine Extra-Zelle rot formatierst. Du kannst auch die betreffenden Zellen selbst, oder die ganze Zeile rot markieren.

Das geht so.

Markiere in der Tabelle A5 und B5 --> gehe auf bedingte Formatierung, lege die Formatierung mit der Formel an:

=ZÄHLENWENNS($A:$A;$A5;$B:$B;$B5)>1

Wähle die Formatierung aus und gib dann in der Übersicht der bedingten Formatierungen bei "wird angewendet auf" ein: $A:$B

Dann werden jeweils die Zellen in A und B formatiert.

LG, Chris

0

Was möchtest Du wissen?