Mehrere Anweisungen in Excel

...komplette Frage anzeigen

6 Antworten

Hallo DolGuldur,

Nee, das geht so leider nicht. Die Worksheet-Funktionen von Excel geben nur einen primitiven Datentyp zurück. Du musst deine Funktion splitten: in die Zelle, in der der X-Wert berechnet wird, schreibst du deine Funktion ohne "y=2" bez. "y=0" und in die für den Y-Wert halt ohne "x=1" und "x=0". Das wäre dann sowas:

A1:

=WENN(EvaluationA;1;0)

A2:

=WENN(EvaluationA;2;0)

Dann ist die Zelle "A1" die X- und die Zelle "A2" die Y-Zelle...

Grüsse

Higlav

PS: Um doch ein wenig mehr in nur einer Formel zu schaffen, müsstest du mit VBA eigene Funktionen schreiben.

Danke für's Sternchen :D

0

Ja das geht. Es gibt soweit ich weiß eine WENN Funtion in Excel. Die Variablen x und y sind dann halt Zellen.

Zur Vervollständigung: Ich konnte mein Problem nun lösen, auch wenn ich es nun etwas anders angegangen bin. Ich musste aus einer Text/Zeichen/Zahlen Reihenfolge die letzte Zahl jeweils inkrementieren. zB: %W/1.22.33/4.5.6 Dafür musste ich wissen wieviel Stellen die eingegebene letzte Zahl hat. Ich habe nun mit einem zusätzl. Makromodul namens "UMKEHREN" (auch unter Reverse im Netz zu finden) die ganze Sache umgekehrt sodass ich bis zum Punkt die Stellen abzählen konnte mit der Funktion "Finde".

Aber die Idee mit den zwei Zellen finde ich schon ganz gut, ohne das Makro hätte ich es so gelöst: In einem ersten Schritt lösche ich alles bis zum letzten Punkt, so dass ich nur noch die letzte Zahl habe, welche ich dann problemlos inkrementieren kann. Im zweiten Schritt füge ich den ersten Teil (bis zum letzten Punkt) mit der inkrementierten Zahl wieder zusammen, Also A1&A2.

Ja die WENN Funktion benutz ich ja schon lange erfolgreich, ich bekomm nur die mehreren Anweisungen nicht hin, vorallem wie trennnt man die voneinander...

Hast du mal ein konkreteres Beispiel? Vielleicht kommen wir dann etwas weiter ....

=WENN(A1=1;"ja";WENN(A1=2;"nein";"vielleicht"))

Wenn in A1 eine steht dann "ja" wenn in A2 eine 2 steht dann "nein" bei allem anderen "vielleicht"

Was möchtest Du wissen?