Mehree Bedinungen Excelformel?

... komplette Frage anzeigen

2 Antworten

Also,

wenn du die Berechnung so verändern würdest:(Als Beispiel habe ich die zu berechnenden zahlen aus A1 und A2 genommen und das Ergebnis in A3 anzeigen lassen)

=TEXT(A10-210;"HH:MM")

Könntest du mit dieser Matrixformel die Werte wie gewünscht bekommen:

=SVERWEIS(A3;{"00:00"."Terminvorgabe";"02:01"."";"02:30"."Zeitvorgabe";"08:01"."";"08:30"."Keine Vorgabe";"10:01".""};2)

Liebe Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von CaptainSlow
18.05.2017, 13:11

Hallo,

Ich verstehe nicht ganz.

Ich habe von Spalte M7 und O7 die Stunden in Spalte P7 berechnen lassen.

Der Sverweis gibt mir nur eine fehlermeldung

0

Hallo,

so richtig hab ich die Schilderung nicht verstanden, hört sich aber eigentlich nur nach einer verschachtelten WENN-Funktion an. Soweit ich interpretiere, so:

=wenn(und(A1>=0;A1<=2/24;"Terminvorgabe 02:30";wenn(A1<=8/24;"Terminvorgabe 08:30";"keine Vorgabe")

LG, Chris

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von TestBunny
18.05.2017, 11:22

Er hat 3 Zeiträume gegeben:
00:00 - 02:00h = Terminvorgabe
02:30 - 08:00h = Zeitvorgabe
08:30 - 10:00h = Keine Vorgabe

2
Kommentar von CaptainSlow
18.05.2017, 11:26

Nein nicht richtig verstanden :)

Es geht darum dass wir 3 Lieferzeitfenster haben wie oben beschrieben. 

Kurzerklärt:

  • Wenn Zeitspanne grösser gleich 8:30 ist dann schreibe Keine Vorgaben.
  • Wenn Zeitspanne kleiner gleich 2:00 ist dann schreibe Terminvorgabe
  • Wenn Zeitspanne grösser gleich 02:30 und kleiner gleich 08:00 ist dann schreibe Zeitvorgabe

Dies müsste alles in einer einzelnen Formel sein.

Hoffe jetzt ist es besser erklärt

1

Was möchtest Du wissen?