Matrix in dreispaltige Tabelle umwandeln

... komplette Frage anzeigen

2 Antworten

Ich glaube, diese Lösung ist für dein Problem geeignet: http://www.excelformeln.de/formeln.html?welcher=138

Ist in deiner Tabelle jeder Jahreszahl nur ein Name zugeodnet oder ist die komplette Matrix voll?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Joachim30
14.03.2014, 16:04

Hey, super, vielen Dank für die schnelle Antwort!

Ich habe mal ein bisschen rumprobiert und bei den Werten und den Spaltenüberschriften klappt das auch - bei den Zeilenbeschriftungen aber leider nicht, da bekomme ich immer nur eine 0 ausgespuckt...

Genau genommen habe ich folgenden Aufbau der Matrix: Zeilenbeschriftungen in A4:A36, relevante Spaltenbeschriftungen in N4:T4 und die Werte entsprechend in N5:T36.

In AC5 habe ich die Summe der Spalten angegeben (=7), in AC6 die Summe der Zeilen (=32)

Meine Formel ist nun: =WENN(ZEILE(A1)>$AC$5*$AC$6;"";INDEX(A:A;KÜRZEN((ZEILE(A1)-1)/$AC$5)+1+1))

Wie gesagt kommt 0 raus und das ist wahrscheinlich auch logisch, durchschaue das Ganze aber leider nicht ganz und finde daher den Fehler nicht... Könnt ihr mir noch mal weiterhelfen?

DeeDee07, um auf deine Frage zurückzukommen: nein, die Matrix ist nicht komplett voll, allerdings gibt es nicht einen Wert pro Jahreszahl sondern mal mehrere, mal einen, mal gar keinen. Kür des Ganzen wäre natürlich, wenn nur die Kombinationen in der Tabelle ausgespuckt würden, in denen ein Wert in der Matrix steht... Aber das muss auch nicht sein :)

Danke!

0

Viel besser ist es, bevor man eine Tabelle anlegt, mal einen Moment länger nachzudenken!

  • Welche Daten kommen vor?
  • Wie stelle ich die Daten dar?
  • Welche Ergänzungsmöglichkeiten bestehen?

Dann sind Änderungen später ganz einfach …

Außerdem könnte man die Spalten auch ganz einfach in ein neues Blatt kopieren und dabei Zeilen und Spalten vertauschen …

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Joachim30
17.03.2014, 11:13

Hallo Wolfgang,

da hast du grundsätzlich natürlich recht! Das ändert aber ja nichts daran, dass man manchmal schon bestehende Formulare etc. hat, in die man mit möglichst wenig (optischen) Veränderungen weitere Funktionen einfügen soll. So war es in diesem Fall, aber auch das ließ sich ja - dank eurer Unterstützung - gut umsetzen...

0

Was möchtest Du wissen?