Make tut seinen Job unter Linux Mint 17.2 und Ubuntu 14.04 nicht, was tun?

...komplette Frage anzeigen Die Schritte - (Installation, Linux, Terminal)

2 Antworten

Hallo

cc: error: utils.o: No such file or directory
cc: error: md5.o: No such file or directory
cc: error: sha1.o: No such file or directory
make: ***
[cowpatty] Error 1ddd

Ist das nicht eindeutig genug!?

Es wurde die Datei utils.o nicht gefunden; entweder weil diese nicht existiert oder eben nicht im angegebenen Pfad liegt. Gleiches gilt für die anderen auch.

find / -type f \( -name "utils.o" -o -name "md5" -o -name "sha1" \) 2>/dev/null

Linuxhase

Chriwro 25.10.2015, 13:18

Kannst du mir auch sagen wo ich diese Dateien für Cowpatty 4.6 herbekomme?

0
Chriwro 25.10.2015, 13:24
@Chriwro

den jetzt sehe ich es auch. Ich hatte bis vor einem Halbem Jahr nur mit Ubuntu 8.04 zu tun und da hab ich nichts anderes gemacht als die Games zu zocken

0
Linuxhase 25.10.2015, 13:25
@Chriwro

@Chriwro

Kannst du mir auch sagen wo ich diese Dateien für Cowpatty 4.6 herbekomme?

Du solltest erstmal nachsehen ob die bereits existieren und eventuell nur am falschen Ort gesucht wird → makefile

Linuxhase

0
Linuxhase 26.10.2015, 20:32
@Chriwro

@Chriwo

Ich hab mir das Archiv mal angeguckt und die Dateien nicht gefunden

Das ist schlecht, aber gemeint war nicht der Archivinhalt sondern Dein Dateisystem.

aus der Makefile werd ich auch nicht schlau:(. Wenn du mehr damit anfangen kannst hier

Da es sich um eine reine Textdatei handelt ist ein Screenshot davon Unsinn, lade doch einfach den Text auf einen Paste-Dienst hoch:

cat namedesmakefile | curl -F 'sprunge=<-' http://sprunge.us

Linuxhase

0

Das Terminal kann ich so nicht lesen, da zu klein. Kannst du das Bild noch woanders hochladen (postimg.org z.B.) und einen Link reinstellen?

Hast du alle Abhängigkeiten installiert? Bei Binärdistributionen wie Ubuntu ist oft nicht von Anfang an alles dabei, was man zum Kompilieren braucht, da man im Normalfall eben nicht kompilieren muss.

Hast du diesen Thread hier mal angeguckt?

http://ubuntuforums.org/showthread.php?t=913318

Chriwro 25.10.2015, 13:10

Ich hab mir mal den Thrad angeguckt und alles installiert was dort angegeben wurde, die Fehlermeldung bleibt die gleiche. Ich hab dir den Screenshot hochgeladen http://postimg.org/image/5nme5oa0n/ und da ich die Abhängigkeitspakete nicht kenne kann ich sie nicht installieren.

0
Linuxhase 25.10.2015, 13:15
@Chriwro

@Chriwro

Ich hab dir den Screenshot hochgeladen

Dann schau Dir mal das Makefile genau an.

Linuxhase

0
Christianwarweg 25.10.2015, 13:30
@Chriwro

Sehr nett, da kann man wenigstens mal was lesen. Hilft mir jetzt allerdings auch nicht viel weiter.

Wie Linuxhase oben ja schon schríeb, ist der Fehler, dass diese 3 .o Dateien fehlen. Keine Ahnung, wozu die gehören.

Bei askubuntu hat jemand vorgeschlagen

sudo apt-get install libpcap-dev libssl-dev

Vielleicht hilft's.

1

Was möchtest Du wissen?