Localhost und 127.0.0.1

...komplette Frage anzeigen

2 Antworten

Habs nach endlosem Suchen gefunden. Ich poste es mal hier, falls es noch mal jemandem passiert. Ich weiß nicht, welches Proggi das verbeutelt hat, aber irgendeins hat bei der Deinstallation in der Datei windows/system32/driver/etc/HOSTS folgende Zeile gelöscht: 127.0.0.1 localhost Die Zeile für die 6-ser Version stand noch drin: ::1 localhost So kam das Problem zustande. Und Antwort nein, ich habe keine Viren und nein, ich habe darin nix von Hand geändert (bis heute). Dass die Zeile nimmer da war, muss einen anderen Grund haben, den ich aber nicht kenne. Auf jeden Fall gehts nun dankenswerterweise wieder. Danke trotzdem allen, die sich bemüht haben.

Wenn du eine Internetseite lokal über XAMPP verwaltest. Musst du schon auch das Verzeichnis selber aufrufen, in dem Apache die Seiten verwaltet. Der Aufruf alleine von "localhost" bringt dich da nicht weiter.

Slizia 11.03.2009, 08:19

Das ist mir klar. Aber ich kann z.B. 127.0.0.1/xampp aufrufen, aber localhost/xampp nicht. Ich arbeite schon paar Jahre mit lokalen Servern, aber das Problem ist echt neu seit letztem WIN- Update.

0
Scarecrow69 11.03.2009, 08:27
@Slizia

An Windows kann es eigentlich nicht liegen. Ich selber nutze zum Testen von Seiten VertigoServ und dort hat sich nichts geändert. Wenn die Probleme nicht(!) in der HOSTS-Datei zu finden sind (also der Eintrag 127.0.0.1 localhost) sollte das Problem eher bei XAMMP zu finden sein.

0
Slizia 11.03.2009, 11:30
@Scarecrow69

Genau dort lag der Haken. Da ich da drin aber seit Neuinstallation nix geändert hatte, bin ich gar nit auf die Idee gekommen. Als ich Deinen Kommentar gelesen habe, hatte ichs dann schon raus.

0

Was möchtest Du wissen?