Linux Python Spyder3 installieren GEHT NICHT?

... komplette Frage anzeigen

3 Antworten

Warum verwendest Du nicht Synaptic? Da kannst Du doch direkt sehen, ob Spyder3 in den Paketen ist (sollte es eigentlich, da Mint auf Ubuntu basiert), und Du könntest es direkt zur Installation auswählen. Bei Problemen bekommst Du normalerweise auch angezeigt, wo diese liegen. Und weitere benötigte Pakete (und das sind bei Spyder3 einige) werden Dir nicht nur angezeigt, sondern auch gleich mit installiert.


Antwort bewerten Vielen Dank für Deine Bewertung

Paket spyder3 gibt es wohl nicht und Paket spyder braucht man nicht für Spyder3.

Unter Systemsteuerung-Hardware ist dafür das Modul "Farbe" vorhanden. Spyder3 anstecken und klick ....

Jedenfalls ist das Modul Farbe (Hardware, nicht Erscheinungsbild o.ä.) unter Mint per default installert.

Antwort bewerten Vielen Dank für Deine Bewertung

Hallo

Der sudo apt-get install spyder3 oder sudo apt-get install spyder funktiniert nicht!

Was genau gibt es denn für eine Fehlermeldung?

Bitte einmal lesen:

http://www.the-one-brack.org/linux/getting-help_de.html

Linuxhase

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Linuxhase
25.11.2016, 12:23

Hallo

Also bei mir (Arch-linux) sieht die Suche in den Paketquellen so aus:

pacman -Ss spyder                                          # Das ist die Abfrage
community/spyder 2.3.9-1
Scientific PYthon Development EnviRonment providing
MATLAB-like features for Python 2.x series.
community/spyder3 2.3.9-1
Scientific PYthon Development EnviRonment providing
MATLAB-like features for Python 3.x series.

Eine Installation, bei Arch-Linux, geht dann so:

pacman -S spyder3

Was aber ganze 26 Abhängigkeiten (engl. Dependencies) mitbringt:

ipython-5.1.0-1  jupyter-4.1.0-6  jupyter-nbformat-4.1.0-1  jupyter-notebook-4.2.3-1
jupyter-widgetsnbextension-1:1.2.6-1 jupyter_console-5.0.0-1 python-decorator-4.0.10-1 python-ipykernel-4.5.1-1
python-ipywidgets-5.2.2-2 python-jinja-2.8-2 python-jsonschema-2.5.1-3 python-jupyter_client-4.4.0-1
python-jupyter_core-4.2.0-1 python-mistune-0.7.3-1 python-pexpect-4.2.1-1 python-pickleshare-0.7.4-2
python-prompt_toolkit-1.0.9-1 python-ptyprocess-0.5.1-1 python-pyflakes-1.3.0-1 python-pygments-2.1.3-1
python-pyzmq-16.0.0-1 python-terminado-0.6-1 python-tornado-4.4.2-1 python-traitlets-4.3.1-2
python-wcwidth-0.1.7-1 spyder3-2.3.9-1

So das ich das bei meinem Produktivsystem, auch Testweise, nicht machen möchte.

Für Distributionen welche apt verwenden sähe es demzufolge so aus:

su -c "apt-get install spyder3"

oder eventuell auch:

sudo apt-get install spyder3

Falls sudo bei Dir entsprechend konfiguriert ist!

Linuxhase

0

Was möchtest Du wissen?