Linux Mint: Wieso funktioniert meine Soundkarte nicht?

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Hallo

Ich habe die Soundkarte Asus Xonar DGX eingebaut

Zeig doch mal bitte die Ausgabe folgender Kommandos die Du im Terminal eingibst:

lspci -nnk | grep -iA2 audio
cat /proc/asound/cards 
aplay /usr/share/sounds/alsa/*.wav 

Bitte alle Ausgaben in Code-TAGs setzen oder gleich auf einem Paste-Dienst ablegen.

und mit den Treibern funktioniert sie unter Windows wunderbar

Das ist schön für Dich, hilft aber überhaupt nicht weiter ;-)

aber wie kann ich sie unter Linux Mint 17.3 Cinnamon 64-bit zum Laufen bringen?

Der Lösung kommen wir nur näher wenn wir mehr, und detailliertere, Informationen bekommen.

Ich kenne mich leider noch nicht all zugut mit Linux aus.

Das macht nichts, die Hauptsache ist, Du arbeitest mit an der Lösungsfindung und erwartest nicht das man Dir alles auf dem Silbertablett präsentiert.

Linuxhase

Woher ich das weiß:Eigene Erfahrung – Ich benutze seit 2007 Linux und habe LPIC101 und LPIC102

Erst einmal: Sorry, dass ich nicht so schnell auf deine Antwort reagiert habe.

~ $ lspci -nnk | grep -iA2 audio
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT HDMI Audio [Radeon HD 7970 Series] [1002:aaa0]
Subsystem: Tul Corporation / PowerColor Device [148c:aaa0]
Kernel driver in use: snd_hda_intel
--
06:04.0 Multimedia audio controller [0401]: C-Media Electronics Inc CMI8788 [Oxygen HD Audio] [13f6:8788]
Subsystem: ASUSTeK Computer Inc. Device [1043:8521]
Kernel driver in use: snd_oxygen
~ $ cat /proc/asound/cards 
0 [DGX ]: CMI8786 - Xonar DGX
C-Media Oxygen HD Audio at 0xd000, irq 16
1 [Snowball ]: USB-Audio - Blue Snowball
BLUE MICROPHONE Blue Snowball at usb-0000:00:14.0-2, full speed
2 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xf0060000 irq 29

Beim Letzteren konnte ich keinen Ton vernehmen. 

0
@User983202
~ $ aplay /usr/share/sounds/alsa/*.wav 
Wiedergabe: WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Front_Left.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Front_Right.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Rear_Center.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Rear_Left.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Rear_Right.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Side_Left.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
Wiedergabe: WAVE '/usr/share/sounds/alsa/Side_Right.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
0
@User983202

@FreshEFLukas

Erst einmal: Sorry, dass ich nicht so schnell auf deine Antwort reagiert habe.

Kein Ding, es sind ja Feiertage :-)

Du hast zwei Soundkarten die für die Ausgabe in Frage kommen können, folglich muss man dem System mitteilen welche es standardmäßig verwendet soll.

Dies kann man entweder im Terminal tun indem man alsamixer verwendet und darin mittels F6-Taste die Standardkarte auswählt, oder man verwendet einen Desktop der ein grafisches Programm mitbringt.

alsamixer

im Terminal wäre das Kommando; weitere steht dann direkt auf dem Bildschirm des Programms.

  • Welchen Desktop hast Du denn, ist es Unity oder Gnome 3?

Wie man an der aplay Ausgabe sehen kann arbeitet das System soweit richtig, denn es gibt keine Fehlermeldung.

Linuxhase

0

Ich habe Gnome 3. Wenn ich eine Soundkarte ausgewählt habe mit F6 und dann ESC drücke und wieder in die Konfiguration gehe, dann hat sich die Einstellung zurückgesetzt.

0

Hier schau dir mal den an. Hatte mit meinem laptop VGA Treiber auch funktioniert.
Man kann unter Linux auch die Windows Treiber kompilieren, weiß nur grad nicht wie.
Ansonsten schau mal ob der Treiber Assistent (ist in der systemsteuerung diese pcikarte) dir einen anderen vorschlägt.
LG Sven

sorry kann den link nicht eingeben. Google mal nach noobslab Treiber manager

0

lese gerade das diese Soundkarte ab der kernel Version 3.14 unterstützt wird. kernel updates kannst du in der aktualisierungsverwaltung (dieses Schild neben der Uhr unten rechts) machen. nimm am besten den nächsten empfohlenen.

0
@DaSilva88

Danke, das habe ich gar nicht bedacht, jedoch habe ich scheinbar schon den 3.19.0-32-generic Kernel.

0

Hast du schon mal im Internet geschaut, ob es den passenden Treiber für Linux gibt?

Was möchtest Du wissen?