Kundenumsatztabelle clustern?

...komplette Frage anzeigen Cluster zum Umsatz - (Excel, Funktion, Verschachtelte WENN-Funktion)

1 Antwort

Im Grunde musst Du die Reihenfolge der Bedingungen nur umdrehen. Excel prüft bis die erste Bedingung erfüllt ist. Daher landen bei Dir momentan alle Werte >500 in der ersten Kategorie, denn auch 5000 ist ja >500. Excel sucht dann nicht weiter, ob es noch eine andere passende Bedingung gibt.
Also einfach die Bedingungen in der Reihenfolge größter Wert -> kleinster Wert

Der "sonst"-Wert "10k" ist etwas fraglich: Wenn B2 = 50 ist, dann greift ja keine der Bedingungen. Soll das wirklich in die Kategorie "10k"?

Im Kehrschluss: Ein Wert von 20000 würde in der bisherigen Formel auch von >5000 erfasst. Du brauchst also noch eine weitere Wenn-Bedingung >10000

Generell solltest Du prüfen, ob > oder >= richtig ist. Bei >5000 fällt 5000 noch in die vorherige Kategorie


Mit der Wenn-Formel kannst Du zu jedem Wert in der Liste die entsprechende Kategorie hinterlegen. Wenn Du direkt zählen willst, gibt es so:
=SUMMENPRODUKT((B2:B100>=500)*(B2:B100<1000))

bzw. bei der Kategorie 10k
=summenprodukt((B2:B100>10000)*1)

0
@Ninombre

Wenn wir wenn verwennden: ;)

=WENN(P1<1000;"500-1000";WENN(P1>=10000;"10k";WENN(P1<2500;"1-2,5k";WENN(P1<5000;"2,5-5k";WENN(10000>P1;">5k")))))

0

Super, viiiiielen Dank!!

0

Was möchtest Du wissen?