Kennt jemand die Excel-Formel für Gruppenzugehörigkeit?

... komplette Frage anzeigen

1 Antwort

Leider kenne ich mich in Statistik nicht aus und daher habe ich Varianz schon mal gehört, kann aber nicht viel damit anfangen. Ich denke aber, dass Du den Wert des Individuums mit dem Durchschnittswert der Gruppe vergleichen willst. Den Durchschnittswert der Gruppe bekommst Du für A1 mit:

=MITTELWERTWENN(B1:B4000;B1;C1:C4000)

Wenn dabei allerdings 999999 nicht berücksichtigt werden soll, geht das z.B. so:

=SUMMENPRODUKT(((B1:B4000=B1)*(C1:C4000<>999999)*(C1:C4000))/SUMMENPRODUKT((B1:B4000=B1)*(C1:C4000<>999999)))

Hilft Dir das weiter?
(Es kann sein, dass das auch einfacher geht, ich neige zum verkomplizieren, aber klappen sollte es.)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von island03
30.10.2015, 11:31

Hallo Oubyi, danke für deinen Tipp! Das trifft leider nicht ganz das, was ich brauche. Nur, um das hier zu vervollständigen: Aus einem anderen Forum habe ich gerade diese Lösung bekommen:

=WENN($B2<>$B3;VAR.P(WENN(($B3=$B$2:$B$11)*($C$2:$C$11<>999999);$C$2:$C$11));"-")

(Spalten A bis C wie oben beschrieben). Trotzdem lieben Dank für deinen Hinweis!

1

Was möchtest Du wissen?