Kann mir jemand in Excel helfen wegen paar Formeln?

...komplette Frage anzeigen Fahrplan - (Computer, PC, Schule)

3 Antworten

Hallo,

die Antwort von Heiratsanthrax ist richtig. Was ich ergänzen möchte ist folgendes: Wenn du in C20 und C21 Formeln drin hast, kannst du ja nicht gleichzeitig in die Zellen Zahlen eingeben (dann würden die Formeln ja überschrieben werden). Wenn du das tust, kannst du aber wiederum in C18/C19 kein Ergebnis aus einer Formel erwarten, da die Felder ja wiederum leer sind und Zahlen als Eingabe erwarten.

Entweder

du machst das über zwei Spalten (in C Eingabe der Bhf-Nr/in D Eingabe der Zeit)

oder

das schaffst du nur mit Makros. Dann könnte das Makro testen, in welcher Zeile du gerade etwas eingetragen hast und die entsprechend anderen Werte auslesen und in die dazugehörigen Zeilen schreiben. Dann steht aber nirgendwo eine Formel, sondern das musst du dann eben mit VBA berechnen / auslesen lassen.

Antwort bewerten Vielen Dank für Deine Bewertung
  • Abfahrt: =index(d5:d16;Vergleich(c18;a5:a16;0)
  • Ankunft: =index(c5:c16;Vergleich(C19;a5:a16;0)

Erklärung: Vergleich sagt, in der wievielten Zelle des Bereichs A5:A17 der Wert aus C18 (bzw c19) zu finden ist, index liest diese Zellnummer aus dem Bereich d5:d16 (bzw c5:c16) aus.

da man bei dieser Formel sieht, aus welcher Spalte index den Wert holt, halte ich sie für übersichtlicher als den SVerweis. (hat noch ein paar andere Vorteile: Die Vergleichsspalte kann auch weiter rechts stehen, beim Kopieren der Formel wandert die Auslesespalte mit (aber dann $A5:$A16  verwenden, denn die Vergleichsspalte muss ja dieselbe bleiben!) und wenn Du wissen wilst, welches der nächste Halt nach Essen(=4) ist, dann

=index(B5:B16;Vergleich(4;A5:A16;0)+1)

Sieht man hier zwar auch sofort und man könnte auch 5 eingeben, aber die Nummern könnten ja in anderen Darstellungen auch Postleitzahlen sein, völlig durcheinander, oder Bahn-interne Schlüsselzahlen, die Du nicht deuten kannst!

  • Oder praktisches Beispiel ohne Nummern:der letzte Halt vor Binz, dann ...
  • =index(B4:B16;Vergleich("Binz";B5:B16;0)-1)

Wichtig ist, dass die Bereiche von Index und Vergleich die gleiche Anfangszeile haben.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Schlauer1803
07.02.2017, 15:03

und wenn das mit sverweis macht. weil wir das tema gerade haben

0

Hallo Schlauer1803!

Soweit ich verstanden habe, was du meinst, gehört in C20:

=WENN(C18<>12;SVERWEIS(C18;A5:D16;4);"")

und in C21:

=WENN(C19<>1;SVERWEIS(C19;A5:D16;3);"")

LG Thrax

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?