Kann mir das vielleicht jemand erklären? Ich soll es mit der "Wenn-Funktion" lösen.?

... komplette Frage anzeigen

7 Antworten

Wichtig wäre ja, dass Du danach nicht nur eine fertige Formel hast, sondern auch verstanden hast, wie es funktioniert. Sonst ist zwar die Aufgabe für heute gelöst, beim nächsten Mal stehst Du aber wieder blank da.

Grundlage zur Wenn-Funktion:
Wenn(DieBedingung = WAHR;DannMachDies;SonstMachJenes) http://www.online-excel.de/excel/singsel.php?f=95

Die Bedingung ist bspw. ob der Ausstattungstyp = A ist.
=WENN(B9="A"
DannMachDies: Mietpreis für Ausstattung A aus D4 * Wohnfläche aus C9
SonstMachJenes: Wenn es nur A oder B gibt, kann man es sich hier einfach machen: Wenn die Bedingung B9="A" nicht erfüllt ist: Ausstattung B aus D5 * Wohnfläche aus C9

Zusammengebaut also
=wenn(B9="A";D4*C9;D5*C9)

Man könnte natürlich statt D4 und D5 einen konkreten Wert 6,95 bzw. 5,3 reinschreiben. Das ist aber kein sauberer Stil, denn wenn sich dieser Wert ändert, dann muss man diesen in jeder Formel anpassen. Mit Verweis auf die Zelle kannst Du in diese Zelle einfach einen neuen Wert eintragen und es wird automatisch neu gerechnet.

Ergänzung Nr. 1:
Du willst die Formel ja auch für die anderen Mieter verwenden. Dazu kann man sie runterziehen (also die Zelle rechts unten "packen" und ziehen) oder kopieren / einfügen. Dabei wird in Excel automatisch die Zeilennummer in der Formel erhöht. Das ist meistens so gewünscht, manchmal aber auch nicht. Hier soll der Zeilenwert automatisch erhöht werden für Ausstattungstyp und Wohnfläche. Die Werte für den Mietpreis in D4 und D5 müssen aber weiterhin aus diesen Zeilen gelesen werden. Dafür kann man den Zeilenwert mit dem $ fixieren, dann wird dieser nicht erhöht beim Runterziehen bzw. Kopieren. Das gleiche geht auch mit Spalten, spielt hier aber keine Rolle.

=wenn(B9="A";D$4*C9;D$5*C9)

Ergänzung Nr. 2:

Strenggenommen müsste man zusätzlich abfragen, ob denn in dem Fall, dass der Ausstattungstyp nicht A ist, tatsächlich B hinterlegt ist. Es könnte ja auch noch C, leer oder sonst was sein (Fehleingabe, dicke Finger usw.). Das führt zu einer verschachtelten Wenn-Formel. Ist das schon Thema bei Euch? Sonst hör an der Stelle aus, bevor es verwirrt...

Man kann an die Stelle von SONST eine weitere Wenn-Abfrage packen:

=wenn(B9="A";D$4*C9;wenn(B9="B";D$5*C9;""))

Wenn B9=A, dann wird D4*C9 gerechnet, wenn nicht, dann beginnt die nächste Wenn-Abfrage. Es wird geprüft, ob B9=B ist. Ist dies der Fall erfolgt die Rechnung mit D5*C9. SONST (wenn also nicht B) bleibt das Feld leer

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Funfroc
24.11.2016, 18:31

Erklärbär... Top!

2
Kommentar von schmiddi1967
25.11.2016, 11:09

Richtig :))))) 👍

1

Hallo,

eine Lösung hat dir ja EndyMeex schon gegeben. Schau dir den Aufbau der Funktion genau an, damit du es später selbst nachbilden kannst.

Über das Funktionszeichen (fx) neben der Bearbeitungsleiste liefert dir Excel auch die Syntax, die es für die Formel verlangt. Das funktioniert für jede Funktion.

Lerne darüber die Funktionen aufzubauen. Mit der Zeit verstehst du den Aufbau dann und kannst ohne den Assistenten arbeiten.

Kommt eine neue Funktion hinzu, probiere es zunächst wieder über den Assistenten. Die Beschreibung der Excel-Macher ist nicht immer gelungen, aber bei den meisten "einfacheren" Funktionen solltest du damit hinkommen.

Zum Thema $-Zeichen in der Formel von EndyMeex... hier ist das Stichtwort absolute und relative Adressierung. Schau dir dazu am besten mal das hier an: http://www.excellernen.de/excel-formeln-teil-3-relative-absolute-adressierung/

LG, Chris

Antwort bewerten Vielen Dank für Deine Bewertung

Hallo :),

ich will hier auch mal meinen Senf dazu geben, einfach weil die Plattform dafür da ist :D

Also Lösung 1, wie du es wolltest:

Jahresmiete:

=WENN(B9="A";C9*$D$4*12;C9*$D$5*12)

Die Formel kannst du dann einfach runter ziehen und kopieren.

Gesamtkosten:

=SUMME(D9:E9)

Veränderung im Vorjahr:

=(F9/100)*G9/100

(Für den %-Wert musst du noch auf das % Zeichen klicken)

Du könntest das aber auch mit so einer Formel machen: (Falls z.B. noch Typ C, D, E, ... dazukommen sollten)

Jahresmiete:

=WENN(B9=RECHTS(C4;1);C9*$D$4*12;C9*$D$5*12)

Ansonstn, wäre das alles.

Grüße,

iMPerFekTioN

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn Zelle B A ist dann Wohnfläche * (Zelle anklicken zu TypA, der Preis) *12 (Monate)

Also telefonisch könnte ich es besser erklären xD hoffe wird trotzdem einigermaßen verstanden

Antwort bewerten Vielen Dank für Deine Bewertung

Wäre gut, die Zellenbezeichnung mitzuposten. Dann kann man auch die genaue Formel angeben

Antwort bewerten Vielen Dank für Deine Bewertung

wenn(ausstattungstyp=A)dann(jahresmiete=6,95*qm*12)sonst(jahresmiete=5,3*qm*12)

gesamtkosten=jahresmiete+nebenkosten


wenn(gesamtkosten>gesamtkostenVorjahr)dann(veränderung=((gesamtkosten/gesamtkostenVorjahr)-1)*100)sonst(veränderung=((gesmtkostenvorjahr/gesamtkosten)-1)*100*(-1))


musst es nur noch in excelformat abtippen ;)
zu veränderung in %: wenn du jetzt mehr zahlst als das jahr davor, dann ist die veränderung +xy%
wenn du jetzt weniger zahlst dann -xy%

ps.: hoffe ich hab mich nicht vertippt (bzw. kleinen denkfehler) und du kannst es nachvollziehen

Antwort bewerten Vielen Dank für Deine Bewertung

D9: =C9*12*WENN (B9="A";$D$4;$D$5)
F9: =E9+D9

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von augsburgchris
25.11.2016, 00:09

H9: G9/F9-1 Spalte H als % formatieren

0

Was möchtest Du wissen?