Kann man Zellen in Excel für bestimmte nur für bestimmte Zeichen Frei geben?

...komplette Frage anzeigen

2 Antworten

Daten → Datentools → Datenüberprüfung

Gültigkeitskriterien → Zulassen → Liste → Quelle: X;O

Antwort bewerten Vielen Dank für Deine Bewertung

Du kannst die Gültigkeit von Zellen einschränken.

(Bei Excel mit dem alten Menü unter Menü "Daten" -> "Gültigkeit"; bei Excel mit dem Ribbon - viel Spaß beim Suchen!)

Anscheinend kann man in einer Gültigkeitsformel nicht auf Funktionen zugreifen, deshalb muss man wohl das zulässige Zeichen in eine eigene Zelle schreiben.

Sagen wir mal, du schreibst in E1:

Am Zug:

und in F1 die Formel eintragen:

=WENN(ISTGERADE(ANZAHL2($A$1:$C$3));"X";"O")

(oder "X" und "O" entsprechend vertauscht)

dann kannst du in A1:C3 die Gültigkeit so eintragen:

- A1 bis C3 markieren

- Dialog zur Gültigkeitsprüfung anzeigen lassen (siehe oben)

- "Benutzerdefiniert" auswählen

- Formel eintragen:

= (A1=$F$1)

- mit OK bestätigen (die Formel wird automatisch für die übrigen markierten Zellen angepasst)

(Nachteil: auch Kleinbuchstaben werden akzeptiert)

Antwort bewerten Vielen Dank für Deine Bewertung
PWolff 13.06.2016, 11:36

Nachtrag: Die Formel in F1 (oder entsprechend andere Zelle) wird
ausgewertet, NACHDEM der neu eingetragene Wert vorläufig übernommen
worden ist, d. h. wir brauchen eine 2. Zelle, die "unsichtbar"
formatiert ist, z. B. F2, mit

=WENN(ISTGERADE(ANZAHL2($A$1:$C$3));"O";"X")

(also andersrum als in F1) und als Gültigkeitsformel

= (A1=$F$2)

-----

Nachtrag2: Das Verhindern von Überschreiben bereits gesetzter Werte muss auch noch verhindert werden

1

Was möchtest Du wissen?