Kann man in Excel mit VBA eine Zelle wie folgt programmieren?

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Dafür könntest Du die Datenüberprüfung nutzen.

Benutzerdefiniert > Formel
=ANZAHL(B1:F1)=5
bzw. entsprechend angepasst auf den Bereich, den Du prüfen willst.

Nur wenn die Bedingung erfüllt ist, lässt sich etwas in die Zelle eintragen.

Unter Fehlermeldung kannst Du auch was sprechendes hinterlegen bzw. die Art des Hinweises anpassen (d.h. ob man trotz des Fehlers etwas eintragen kan oder nicht)

 - (Excel, Formel, VBA)

Wenn ich den Kommentar zur anderen Antwort richtig verstanden habe darf der Wert in A1 nicht größer sein als die Anzahl von Zahlen in einem bestimmten Bereich. Unter der Annahme, dass dieser Bereich B1:F5 wäre, ist die Formel für die Datenüberprüfung:

=ANZAHL(B1:F5)>=A1

0

Danke ich werde es morgen noch mal probieren

0

Hier eine nicht VBA Lösung:

Angenommen, du schreibst die Zahl in $A$1. Dann kannst Du dort als erstes eine Datenprüfung auf eine Ganze Zahl machen.

Für die Zahlenreihe machst Du dann eine bedingte Formatierung, welche sich immer auf $A$1 bezieht.

Formel: =WENN($A$1=B1;WAHR;FALSCH)

Daten - Datentools - Datenüberprüfung - (Excel, Formel, VBA) Bedingte Formatierung. Formel siehe im Text. - (Excel, Formel, VBA) Jetzt leuchten alle 5er auf, wenn ich 5 als Suche in $A$1 eingebe. - (Excel, Formel, VBA)

Vielleicht hab ich es schlecht erklärt, ich versuche es noch mal, nehmen wir an A1 ist die bestimmte Zelle, ich gebe nun eine 1 ein, für meinen Suchlauf sagen wir A2 bedeutet das nun ich möchte dort eine Zahl sagen wir aus dem Bereich D1:F10 , dieser Bereich ist immer unterschiedlich mit Zahlen gefüllt oder aber auch mal keine, aber da ich in meinem Fall den Bereich nicht im Blickfeld habe so wie im Beispiel möchte ich gewarnt oder daran gehindert werden wenn der Bereich keine Zahlen enthält und somit der Suchlauf ins leere laufen würde .

0
@Marceloblau01

Vielleicht mit der Formel =Zählenwenn()

Damit kannst Du nachprüfen, wie oft ein Wert in einem anderen Bereich vorkommt. Wenn der Wert 0 ist, weisst Du, dass Du kein Resultat gefunden hast.

=ZÄHLENWENN(B1:B11;A1)

ergibt bei meinem Beispiel 5, weil die 5 total 5x in der anderen Reihe vorkommt.

0
@Willwissen100

entschuldige bitte, aber den Wert den ich in A1 eingebe , ist nicht der Wert den ich suche sondern die Anzahl der Zahlen die mir aus diesem Bereich geliefert werden sollen , die Zellen ab A2 sind bereits auf bestimmte Zahlenbereiche programmiert, das heißt erst wenn ich in A1 einen Wert eingebe ob 1,2,3 ist die Anzahl der Zahlen die ich aus dem bestimmten Bereich haben möchte, aber ich möchte dass ich gewarnt werde das der Suchlauf ins leere läuft da in dem bestimmten Zahlenbereiche sich im Moment keine Zahlen befinden die der Suchlauf liefern könnte. noch komfortabler wäre es noch wenn ich 2 eingebe und dort in dem Bereich befindet sich nur eine Zahl die der Suchlauf liefern könnte , dass dann ebenfalls eine Warnung erscheint.

0

EXCEL VBA Werte in Bezug auf andere Zelle einfügen

Hallo miteinander. Habe eine Tabelle auf der auf Zeile D verschiedene Zahlen mehrmals vorkommen. Auf der Nachbarszeile E sind nur z.T. Werte vorhanden. Nun suche ich ein VBA das mir ermöglicht die leeren Zellen von E mit den jeweiligen Werte von Zelle E in Bezug auf der Nachbarszelle D auszufüllen.

Für eure Hilfe und Tipps jetzt schon vielen Dank

...zur Frage

EXCEL VBA mit Drehfeld aus Zellbereich in Bestimmte Zelle(n) Springen

Hallo,

ich möchte mit einem Makro durch betätigen eines Commandbuttons oder Drehfeldes aus einem Bestimmten Zellbereich in eine definierte Zelle Springen. Beispiel: Wenn eine Zelle im Bereich B1:C8 aktiv ist soll in Zelle E1 gesprungen werden. Ich habe schon verschiedenes mit Select Case und If Funktionen ausprobiert, scheitere aber irgendwie an meinem fehlenden Grundwissen, da ich noch recht neu in der Materie bin. Frage wäre wie man das oben beschriebene Problem nun angehen könnte?

...zur Frage

Kann man mit VBA eine Zufallszahl aus einem Zellbereich der mit verschiedenen Zahlen gefüllt ist programmieren?

Hallo liebe Experten, ist folgende Aufgabe mit VBA zu lösen ? : Zellbereich A1:A10 ist gefüllt mit unterschiedlichen Zahlen und ich möchte eine zufällige Zahl aus diesem Zellbereich , es ist wichtig dass nur eine zufällige Zahl aus diesen Zahlen die in dem Zellbereich vorkommen gewählt wird. Es gibt kein minimum und keine maximum Angabe , die Zahlen in dem Bereich ändern sich ständig und somit kann ich mich auch nicht auf einen bestimmten Zahlenbereich festlegen zB. 1-100. Ist sowas überhaupt machbar? für eure Hilfe wie immer sehr dankbar MfG Uwe

...zur Frage

Kann man ein Makro erstellen, dass einen Zufallsgenerator so lange laufen lässt bis eine bestimmte Bedingung erfüllt ist?

Hallo liebe Excel Experten, ich habe einen Zufallsgenerator der mir 6 aus 49 Zahlen , also Lottozahlen , ausgibt. Ich verwende aber für die Lottozahlen eine Schablone , die mir immer dann in einer Zelle eine 1 anzeigt , wenn Zufallszahlen erstellt wurde die bestimmte Bedingungen erfüllen, jetzt möchte ich aber nicht pausenlos die Enf. Taste drücken bis in der von mir bestimmten Zelle eine 1 erscheint. Kann mir vielleicht jemand , unter der Voraussetzung dass das überhaupt geht, ein Makro schreiben das dieser Zufallszahlen so lange generiert bis in der Zelle eine 1 steht? ich möchte dann den Zufallsgenerator immer dann per Button wie neu starten.

wie immer für reichlich Vor und Ratschläge sehr dankbar

MfG Uwe

...zur Frage

Was möchtest Du wissen?