Kann man in einer Excel Tabelle 2 Bedingungen gleichzeitig eingeben? Ich nutze Excel in Version 15.31 (deutsch)

...komplette Frage anzeigen

3 Antworten

das kannst du so erreichen 

=WENN(O5>0;O5-O5/4*(JAHR(H5)>2008);O5)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Kelevra256
03.03.2017, 19:25

Hi!

Danke für deine Nachricht! Was mache ich aber, wenn das Datum mit 01.01.2008 (Tag Monat Jahr) angegeben ist?

0

Du kannst bis zu 6 Wenn-Bedingungen ineinander verschachteln. Das sollte Dein Problem lösen.

Beispiel:

WENN(A2>89;"A";WENN(A2>79;"B";WENN(A2>69;"C";WENN(A2>59;"D";"F"))))

Du kannst sogar ziemlich endlos Bedingungen "addieren"...wenn die eine nicht erfüllt ist, dann gibt das einfach den Wert 0 oder ""... dann addierst Du die zweite dazu... .die dritte... usw. 

Hier ein krasses Beispiel, wie man mit dem Additionstrick mehr als 6 Bedinungen gleichzeitig meistern kannn:

WENN(C5="";"")+WENN(C5="LP";WENN(C3=20;212;WENN(C5="LP";WENN(C3=21;212;214))))+WENN(C5="LG";WENN(C3=20;112;WENN(C5="LG";WENN(C3=21;112;114))))+WENN(C5="LG ST_A";133;WENN(C5="LG SI_A";123))+WENN(C5="LG_3";WENN(C3=20;153;WENN(C5="LG_3";WENN(C3=21;153;156))))+WENN(C5="LG_L";WENN(C3=20;143;WENN(C5="LG_L";WENN(C3=21;143;146))))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Smartass67
03.03.2017, 14:52

Ich fürchte, das wird dich ein paar Körner kosten aber ich denke, Du kapierst das. Einfach in der Wenn-Bedingung eine weitere einbauen.

Der zweite Teil ist nur für den Fall, wenn man sechs nicht reichen..  oder für Faulenzer und Leute, denen das Schachteln zu kompliziert ist - wenn du das genau anschaust, ist diese Logik nämlich einfacher umzusetzen.

0
Kommentar von DeeDee07
03.03.2017, 15:36

Seit Excel2007 kann eine Formel bis zu 64 Klammer-Ebenen, und damit WENN-Verschachtelungen enthalten.

Trotzdem ist das natürlich eine recht unübersichtliche Methode; da sind [S/W]Verweise anschaulicher und einfacher.

1
Kommentar von Jackie251
03.03.2017, 19:39

was redest du für ein Unfug?
-Wenn lässt sich in 64 Ebenen verschachteln
-Deine Lösung hat nichts mit der einfachen Frage des FS zu tun
-deine Beispiel Wenn Funktion ist Käse zum Quadrat. Was bitte soll Wenn(C5="";"")+ bewirken?

WENN in C5 nichts steht, dann entsteht immer der Einstag "" +...
Was immer zum Fehler Wert führen muss, denn "" + eine Zahl kann Excel nicht auswerten.

Wenn in C5 etwas steht führt die Wenn Funktion zum "oder" und dort steht nichts.

Entweder also wirkungslos oder produziert Fehler..

0

Soweit ich weiß, kann man doch Bedingungen auch mit "AND" bzw. "OR" verbinden. Wie es in deinem Excel exakt aussieht, weiß ich aber nicht.

Ein Beispiel auf Englisch:

=IF(AND(B6>=$B$2, B6<$B$3),B6*$B$1,"No bonus")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Smartass67
03.03.2017, 14:53

Ja, das funktioniert im vorliegenden Fall auch. Viele Wege führen nach Rom.

0

Was möchtest Du wissen?