Kann man die Dropdownfunktion in Excel mit einer Wenn/Dann-Formel kombinieren, bzw. ist es möglich die Auswahl zu begrenzen bis eine Summe X erreicht ist?

... komplette Frage anzeigen

1 Antwort

Wenn Du nicht die Liste für ein Dropdown zwingend brauchst, kannst Du bei Datengültigkeit auf benutzerdefiniert gehen und die beiden Bedingungen mit einer Formel abfragen:

=UND(B2<=10;SUMME(B$2:B$100)<=400)
In Spalte B stehen bei meinem Beispiel die Karten je Kunde. Über die Formel ist die Grenze von 10 pro Kunde und insgesamt 400 gesetzt. Es kommt aber die gleiche Fehlermeldung, es lässt sich da nicht unterscheiden, welche Grenze überschritten wurde. Bei Fehlermeldung kannst Du einen Text hinterlegen, der die beiden Grenzwerte erläutert.

Eine andere Möglichkeit wäre die gültige Menge dynamisch zu ermitteln, wenn die Menge unbedingt über ein Dropdown eingegeben werden soll:
Meine Beispielliste, die als Liste in der Datengültigkeitsprüfung hinterlegt wird, steht von F1-F10
=WENN(SUMME(B$2:B$100)<=400-ZEILE(A1);ZEILE(A1);"")
Das generiert die Werte 1-10, solange die Gesamtzahl unter 400 liegt, kommt die Gesamtzahl der 400 näher, reduziert sich die Auswahlmenge bzw. ist irgendwann komplett leer. Allerdings: Ich bekomme da keine Logik eingebaut, dass eine bereits getroffene Auswahl wieder verringert werden kann - das ist der Fall, wenn ein Kunde bspw. 10 Karten bereits hinterlegt hat und die Gesamtmenge aufgebraucht ist. In diesem Fall ist die Auswahlmöglichkeit nur "nichts", obwohl es ja sinnvoll wäre eine Zahl kleiner der bisherigen Auswahl zuzulassen. Das sprengt aber die Möglichkeiten der Datenprüfung an dieser Stelle.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Elenor12
09.08.2016, 11:27

Vielen lieben Dank für die Hilfe. Da das doch alles sehr umfangreich ist, werde ich den Dropdown entfernen und mit Hinweisen arbeiten (in der Hoffnung meine Kollegen können auch gut lesen ;) )

0

Was möchtest Du wissen?