Kann man das automatische Vervollständigen einer Zelle auf die ganze Zeile erweitern?

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Wäre das für Dich vielleicht eine Hilfe?:
Du schreibst in die Spalten B bis ... unterhalb der ausgefüllten Zeilen eine SVERWEIS()-Formel, die in den Zeilen darüber in Spalte A nach dem Wert sucht, den Du gerade in Spalte A in der freien Zeile eingetragen hast und dann die Werte in B bis ... einträgt.
Diese Formel kannst Du runterziehen bis "ultimo" und gegebenenfalls überschreiben.
Voraussetzung ist, dass die Liste immer nur UNTEN ergänzt wird.
Wenn also z.B. die Zeilen 1 bis 4 ausgefüllt sind, dann schreibst du in B5 die Formel:

=SVERWEIS(A5;$A$1:B4;2;0)   

und ziehst sie runter. Entsprechend auch die anderen Spalten.
Wenn Dich das #NV stört, dann nimm diese Formel:

=WENN(ISTNV(SVERWEIS(A5;$A$1:B4;2;0));"";SVERWEIS(A5;$A$1:B4;2;0))

Bei Problemen frage nochmal nach.

PERFEKT!!! Genauso wollte ich das haben!!! Dem ist nichts mehr hinzuzufügen!!! DANKE!!!

0

Ich hoffe, ich hab deine Frage richtig verstanden... Aber ich denke, dass das Autovervollständigen so wie du es brauchen würdest, leider nicht funktioniert. Die Autofill-Funktion bezieht sich nur auf eine Zelle, nicht auf eine Zeile.

Was aber - sofern praktisch für dich durchführbar - die Sache erleichtern könnte, wäre eine Eingabe der Zeilen nach Themen. Heißt: Du gibst zuerst alle "Apfel-Zeilen" ein, dann die "Birnen-Zeilen" und dann die "Karotten-Zeilen". Denn dann kannst du die Zeilen immer von oben übernehmen (alle betroffenen "Apfel-Zellen" /eigentlich die ganze erste Zeile/ markieren und dann einfach mit der Maus auf das rechte untere Ende, draufklicken, Finger drauf lassen und bis zur letzten "Apfel-Zeile" runterziehen). Spart zumindest die C&P-Zeit, sofern das für dich überhaupt praktisch umsetzbar ist.

Danke für die Antwort! Leider geht das so nicht, da es sich um unterschiedliche Rezepte handelt, deren Zutaten beieinander stehen sollen ...

0

Danke für die Antwort! Leider geht das so nicht, da es sich um unterschiedliche Rezepte handelt, deren Zutaten beieinander stehen sollen ...

0

Wie kann ich in Excel eine Formel =SUMME(ZÄHLENWENN( nach rechts in die Spalten kopieren und Excel in den Suchkriterien eine Zeile nach unten geht?

Hallo liebe Excel Experten,
Ich habe eine Tabelle von $B$1:$G$1000 jetzt möchte ich die Formel =SUMME(ZÄHLENWENN( anwenden.
Die erste Spalte H Zelle 1 wäre dann {=SUMME(ZÄHLENWENN($B$1:$G$1;$B1:$G1))}. dann kopiere ich das bis H1000
Spalte I Zelle 1 gleicher Bereich aber Suchkriterien $B2:$G2.
Wer könnte mir die Formel so umbauen das Excel beim kopieren nach rechts in Spalte I,J,K,L usw. in den Suchkriterien automatisch eine Zelle nach unten geht? Ist das überhaupt möglich oder kann man diese Aufgabe auch irgendwie anders lösen?
Für eure Hilfe wäre ich natürlich wieder überaus dankbar.
MfG Uwe

...zur Frage

Suchfunktion in Excel sucht nicht in kompletter Spalte?

Ich möchte eine Spalte nach einer bestimmten Zahl durchsuchen und wenn diese vorhanden ist, dann soll "drin" ausgegeben werden und wenn nicht, dann "nicht drin".

Folgende Formel liegt dem Zugrunde:

=WENN(ISTZAHL(SUCHEN(89;Y:Y));"drin";"nicht drin")

Diese Formel steht in Der Zelle Z563. Nun soll die Formel die ganze Zeile Y nach der Zahl 89 durchsuchen.

Steht in der Zelle Y563 die Zahl 89, dann gibt mir Excel "drin" aus. Steht aber in einer anderen Zelle in Spalte Y die Zahl 89 drin, dann gibt mir Excel "nicht drin" aus.

Ich finde einfach keine logische Begründung, warum Excel nicht die ganze Zeile durchsucht.

Woran kann das liegen?

...zur Frage

Excel zufällig eine Zelle aus einer Spalte auswählen... Wie?

Hallo, ich hab in Excel eine Namensliste mit Spalten für weibliche, männliche und Nachnamen und hätte gerne dass excel mir jeweils eine Zelle aus jeder Spalte anzeigt und das zufällig.

Kann mir da jemand helfen?

...zur Frage

Wie funktioniert diese Funktion in Excel?

Hallo,

ich habe folgendes Problem in Excel. In Spalte A stehen Angebotene Zahlen, in Spalte B stehen die bestellten Zahlen. Diese beiden Spalten gehen über 300 Zeilen und ich möchte eine Statistik erstellen, wieviele Abweichungen es von angeboten zu bestellt gibt. Aber wenn etwas angeboten ist, also in Spalte A steht, aber noch nicht bestellt ist, soll dies nicht in die Summe mit einfließen.

Ich brauche also eine Formel die 2 Bereiche Summiert, vorher jedoch in Spalte B pro Zeile prüft ob dort ein Wert ist, und ist dies nicht der Fall soll der Wert der Spalte A nicht beachtet werden. Anschließend Subtrahieren und mir in einer Zelle einen Wert ausspucken. Hat jemand eine Lösung?

Danke im voraus :)

...zur Frage

Open Office Calc: Wie kann man Funktionen auf ganze Spalten anwenden?

Hallo,

ich habe ein Open Office Calc Sheet mit 2 Spalten: A. Gesamtanzahl B. Teilzahl

Jetzt möchte ich in einer dritten Spalte für jede Zeile den Prozentanteil von der Zelle in Spalte B zu Zelle in Spalte A. Für Zeile 1 wäre C1 also =B1/A1*100.

Da ich aber 200 Zeilen habe, möchte ich das nicht für jede Zeile hinschreiben. Gibt es sowas wie Cx=Bx/Ax*100? Und wenn ja, wie mach ich das?

Vielen Dank für die Hilfe!

...zur Frage

Excel nächste freie Zelle in Spalte ermitteln?

Hallo,

wie kann ich in Excel aus Tabellenblatt 1 bestimmte Daten aus der neu beschriebenen Zeile (Zeile n, Spalte B, C, E F) in Tabellenblatt 2 transferieren und dort in die nächsten freien Spalten einfügen (Spalte n, A, B, C, D)?

...zur Frage

Was möchtest Du wissen?