Kann man in Excel automatisch ein Datum eintragen, wenn der Monat vorgegeben ist und das nur für Montag-Freitag ?

3 Antworten

schau mal, ob Dir der Kommentar in meiner AW zu dieser Frage eine Anregung gibt:

www.gutefrage.net/frage/halloich-habe-fuer-jeden-monat-eine-registerkarte-wie-geht-es-das-ich-nur-den-tag-1-eingebe-und-autom-der-monat-dazu-kommt-0112-

Für Wochen müsstest Du innerhalb der Formel, noch einen Faktor einfügen.

Ansonsten solltest du angeben, ob Du jedem Tag eine Zeile zuweist (so wie in meiner AW) oder eine Spalte und wo der Beginn sein soll.

Soll die Woche So (am System und früher eorop.) oder Mo(europ.) beginnen?

zB ist die PrüfungsFormel für den 1. So im Monat:

=(Rest("4.Okt.15";7)=1)*(Tag("4.1015")<Tag("4.10.15"-7))

oder

der vorhergehende Samstag ist immer =GANZZAHL(HEUTE()/7)*7

auf ihn kann man sich zB beziehen wenn man anstatt heute() auf ein beliebiges Datum verweist. Mit +1 = So oder -1 =Fr , um weitere Möglichkeiten zu beschreiben.

nur mal als Einstimmung.

(dieser arg verschlimmbesserte Editor erlaubt kein Einfügen von Formeln/Texten, die ein < enthalten, schreiben kann man es!)

Ich hoffe ich habe die Frage richtig verstanden: Tabelle1 stellt die erste Woche des Monats dar, entsprechend Tabelle 2 die zweite Woche etc.

Also mit Formeln würde ich mir die Finger dabei brechen, geht vielleicht auch irgendwie. Mit VBA wäre es so denkbar:

Sub datumsetzen()
Dim tag As Integer
Dim wochentag As Integer
tag = 1
wochentag = Weekday(Tabelle1.Cells(1, 1).Value, vbMonday)
If wochentag = 6 Then
tag = 3
wochentag = 1
End If
If wochentag = 7 Then
tag = 2
wochentag = 1
End If

While wochentag < 6
Tabelle1.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle2.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle3.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle4.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
If tag > Day(DateSerial(Year(tag), Month(tag) + 1, 0)) Then Exit Sub
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle5.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
If tag > Day(DateSerial(Year(tag), Month(tag) + 1, 0)) Then Exit Sub
Wend

End Sub

Annahme hier: Du hat in Tabelle 1 A1 den Monat stehen (August 2015)

Die Schleifen je Tabellenblatt könnte man noch eleganter lösen.

So, die Lösung über Formeln hat mich gereizt, ist aber eine ziemliche Schlacht

Tabellenblatt 1 hat die meisten Sonderfälle abzudecken:
Ich gehe davon aus, dass Du den Monat wieder in A1 stehen hast
Spalte A =WENN(WOCHENTAG($A$1;2)=3;1;WENN(WOCHENTAG($A$1;2)=6;3;WENN(WOCHENTAG($A$1;2)=7;2;"")))
Spalte B =WENN(WOCHENTAG($A$1;2)=2;1;WENN(UND(ISTZAHL(A5);A5>0);A5+1;""))
Spalte C =WENN(WOCHENTAG($A$1;2)=3;1;WENN(UND(ISTZAHL(B5);B5>0);B5+1;""))
Spalte D =WENN(WOCHENTAG($A$1;2)=4;1;WENN(UND(ISTZAHL(C5);C5>0);C5+1;""))

Spalte E =WENN(WOCHENTAG($A$1;2)=5;1;WENN(UND(ISTZAHL(D5);D5>0);D5+1;""))

  1. Tabellenblatt 2 bis 5:Spalte A: =WENN(E5="";"";WENN(E5+3<TAG(MONATSENDE($A$1;0));E5+3;""))Spalte B: =WENN(A8="";"";WENN(A8+1<TAG(MONATSENDE($A$1;0));A8+1;""))

Spalte B kannst Du dann rüberziehen bis E.  Mit den zusätzlichen Prüfungen wird sichergestellt, dass es nicht mehr Tage gibt als der Monat hat.

Ich habe das zum Testen in einem einzigen Tabellenblatt untereinander gemacht. Wenn Du verschiedene Tabellenblätter verwendest, musst Du die Formel in der Spalte A jeweils anpassen.

Excel Tabelle für jeden Tag im Monat

Hallo,

ich suche und suche und finde nichts ! Ich habe folgenes problem ich muss jeden Tag eine Excel Tabelle ausfühlen mit jeweiligen Datum. Jetzt ist es so da es meinen kollegen zu anstrengend ist jedes mal das datum einzusetzen soll ich für denn ganzen monat die Tabelle mit Datum schon erstellen damit sie nur noch ausfühllen müssen. bisheriges vorgehen datum ädern , speichern als, datum ändern usw geht das nicht irgendwie das er es automatisch speichert mit zb 1.1.2013 als datei 1.1.2013 und weiter 2.1.2013 als daitei 2.1.2013

...zur Frage

Excel wochenweise abfragen?

Nach stundenlanger erfolgloser Google-Suche bitte ich wieder mal die Excel-Cracks um Hilfe.

Folgendes habe ich vor:

Ich möchte für meine Abteilung eine Übersicht erstellen die unseren (ebenfalls in Excel erstellten) Urlaubsplan etwas schöner anzeigt.

Dafür möchte ich also eine Adminvorlage erstellen in der ich die Urlaube der Mitarbeiter eintrage und diese dann über eine Excel-Webansicht auf diversen Monitoren anzeigen lasse.

Bis dahin alles gut. Nur möchte ich nach einem bestimmten Schema vorgehen: Es soll in dieser Übersicht nur der aktuelle Monat aus dem Urlaubsplan angezeigt werden und auch nur die Mitarbeiter ausgegeben werden, die in diesem Monat Urlaub haben.

Das ganze könnte sich dann so gestalten, dass man im Kopf das aktuelle Datum mit Tag/Monat/Jahr und Kalenderwoche ausgibt und die aktuelle Kalenderwoche noch farblich hervorhebt aber eben den ganzen Monat anzeigt.

Ich habe den Urlaubsplan auch bereits in verschiedene Spalten extrahiert um die "WENN"-Abfragen besser gestalten zu können. Nur leider komme ich einfach nicht weiter.

Ein weiteres Problem stellt sich mir an späterer Stelle noch: wenn ein Mitarbeiter von Montag bis Montag Urlaub macht kann ich ja einfach über =NETTOARBEITSTAGE(x;y;) nur 5 Tage zählen lassen. Wenn nun allerdings der erste Montag auf den 31.07.2017 fällt würde er mir ja in der Übersicht nicht mehr angezeigt werden. Somit wäre die Überlegung, ob man sich von der aktuellen Arbeitswoche nur eine Woche nach vorn und eine Woche nach hinten orientiert.

Aber dennoch weiß ich einfach nicht, wie ich die Ausgabe realisieren soll.

Ist Excel dafür vielleicht auch einfach nicht geeignet? Was meint ihr?

Ich freue mich auf eure Hilfe!

...zur Frage

Excel: Erster Freitag im Monat anzeigen lassen?

Hey Community,

Ich besitze eine riesen Excel Tabelle mit Daten (Damit ist die Mehrzahl von Datum gemeint)

Ich habe aus dieser Exceltabelle jetzt mithilfe der Formel:

=WENN(ISTFEHLER(FINDEN("Freitag";B4;1));"";"1")

Jeden Freitag ausgefiltert.

Bzw hab ich eine neue Spalte die neben jeden Freitag eine "1 hinschreibt"

Zur Veranschaulichung befindet sich ein Screenshot im Anhang.

Jetzt wollte ich fragen, wie man denn den ersten Freitag im Monat herausfiltert?

Beachtet nicht die Spalte in der Mitte :)

...zur Frage

Was möchtest Du wissen?