Kann man in Excel automatisch ein Datum eintragen, wenn der Monat vorgegeben ist und das nur für Montag-Freitag ?

3 Antworten

schau mal, ob Dir der Kommentar in meiner AW zu dieser Frage eine Anregung gibt:

www.gutefrage.net/frage/halloich-habe-fuer-jeden-monat-eine-registerkarte-wie-geht-es-das-ich-nur-den-tag-1-eingebe-und-autom-der-monat-dazu-kommt-0112-

Für Wochen müsstest Du innerhalb der Formel, noch einen Faktor einfügen.

Ansonsten solltest du angeben, ob Du jedem Tag eine Zeile zuweist (so wie in meiner AW) oder eine Spalte und wo der Beginn sein soll.

Soll die Woche So (am System und früher eorop.) oder Mo(europ.) beginnen?

zB ist die PrüfungsFormel für den 1. So im Monat:

=(Rest("4.Okt.15";7)=1)*(Tag("4.1015")<Tag("4.10.15"-7))

oder

der vorhergehende Samstag ist immer =GANZZAHL(HEUTE()/7)*7

auf ihn kann man sich zB beziehen wenn man anstatt heute() auf ein beliebiges Datum verweist. Mit +1 = So oder -1 =Fr , um weitere Möglichkeiten zu beschreiben.

nur mal als Einstimmung.

(dieser arg verschlimmbesserte Editor erlaubt kein Einfügen von Formeln/Texten, die ein < enthalten, schreiben kann man es!)

Ich hoffe ich habe die Frage richtig verstanden: Tabelle1 stellt die erste Woche des Monats dar, entsprechend Tabelle 2 die zweite Woche etc.

Also mit Formeln würde ich mir die Finger dabei brechen, geht vielleicht auch irgendwie. Mit VBA wäre es so denkbar:

Sub datumsetzen()
Dim tag As Integer
Dim wochentag As Integer
tag = 1
wochentag = Weekday(Tabelle1.Cells(1, 1).Value, vbMonday)
If wochentag = 6 Then
tag = 3
wochentag = 1
End If
If wochentag = 7 Then
tag = 2
wochentag = 1
End If

While wochentag < 6
Tabelle1.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle2.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle3.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle4.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
If tag > Day(DateSerial(Year(tag), Month(tag) + 1, 0)) Then Exit Sub
Wend
wochentag = 1
tag = tag + 2

While wochentag < 6
Tabelle5.Cells(3, wochentag).Value = tag
tag = tag + 1
wochentag = wochentag + 1
If tag > Day(DateSerial(Year(tag), Month(tag) + 1, 0)) Then Exit Sub
Wend

End Sub

Annahme hier: Du hat in Tabelle 1 A1 den Monat stehen (August 2015)

Die Schleifen je Tabellenblatt könnte man noch eleganter lösen.

So, die Lösung über Formeln hat mich gereizt, ist aber eine ziemliche Schlacht

Tabellenblatt 1 hat die meisten Sonderfälle abzudecken:
Ich gehe davon aus, dass Du den Monat wieder in A1 stehen hast
Spalte A =WENN(WOCHENTAG($A$1;2)=3;1;WENN(WOCHENTAG($A$1;2)=6;3;WENN(WOCHENTAG($A$1;2)=7;2;"")))
Spalte B =WENN(WOCHENTAG($A$1;2)=2;1;WENN(UND(ISTZAHL(A5);A5>0);A5+1;""))
Spalte C =WENN(WOCHENTAG($A$1;2)=3;1;WENN(UND(ISTZAHL(B5);B5>0);B5+1;""))
Spalte D =WENN(WOCHENTAG($A$1;2)=4;1;WENN(UND(ISTZAHL(C5);C5>0);C5+1;""))

Spalte E =WENN(WOCHENTAG($A$1;2)=5;1;WENN(UND(ISTZAHL(D5);D5>0);D5+1;""))

  1. Tabellenblatt 2 bis 5:Spalte A: =WENN(E5="";"";WENN(E5+3<TAG(MONATSENDE($A$1;0));E5+3;""))Spalte B: =WENN(A8="";"";WENN(A8+1<TAG(MONATSENDE($A$1;0));A8+1;""))

Spalte B kannst Du dann rüberziehen bis E.  Mit den zusätzlichen Prüfungen wird sichergestellt, dass es nicht mehr Tage gibt als der Monat hat.

Ich habe das zum Testen in einem einzigen Tabellenblatt untereinander gemacht. Wenn Du verschiedene Tabellenblätter verwendest, musst Du die Formel in der Spalte A jeweils anpassen.

In Word Tabelle Ein Datum berechnen

ich versuche gerade eine Word Tabelle zu erstellen, die 3 Spaltig und 25 Zeilig ist.

In der ersten Spalten soll jeweils der Wochenanfang (Montag) mit dem Datumsformat (yy.mm) erstellt werden. In der nächsten Spalte das Wochenende (Freitag) mit dem selben Format sein. Die 3 Spalte soll leer bleiben.

Also so: 30.03 I 03.04

           06.04 I 10.04 usw.

Da ich ein fauler Mensch bin, will ich das Datum nicht jedes Mal in jeder Zelle mit dem Datumssteuerungs Element eintippen.

Ich will dass ich nur das 1. Datum (30.03) einmal eintrage und Word berechnet mir die ganze Tabelle. Am besten über eine Eingabemaske.

Natürlich ist es in Excel mit 2 Mausklicks geschafft, aber ich würde gerne Word dafür nutzen.

Natürlich bin ich für VBA´s offen.

...zur Frage

Excel - Datum automatisch fortsetzen (mit Wochentag-Zuordnung)

Hallo,

ich möchte in Excel einen Arbeitsplan erstellen der automatisiert das Datum, bei Eingabe des jeweiligen Monats in Abhängigkeit des Jahres, fortlaufend in den jeweiligen Spalten einträgt. Hierzu das Tabellenblatt: http://oi45.tinypic.com/2py0oiu.jpg (Die Zusammenfassung der Zellen im Bereich Datum kann hier vernachlässigt werden; stammt aus einem alten Versuch).

Das soll bedeuten: wenn ich bspw. im Kopf bei Monat: "März" eintrage, soll er in der ersten Woche bei Freitag beginnen mit "01.03" und dann fortlaufend auf allen Wochentagen dies automatisiert fortsetzen.

Gibt es hierzu eine Vorgehensweise die mir helfen kann?

Besten Dank im Voraus.

...zur Frage

Wie kann ich in Excel-Pivottabellen mehrere Tabellen u.a. zu einer Pivot-Chart verknüpfen?

Hallo zusammen :-)

Ich würde gerne, ohne meine Daten erneut in EINE NEUE Tabelle hinzuzufügen, die Daten aus meinen erstellten Tabellen (Beispiel: Tabelle1, Tabelle2, Tabelle3) in ein neues Tabellenblatt als PivotChart hinzufügen.

Alle Daten aus den Tabellenblättern 1, 2 und 3 befinden sich bereits in einer dynamischen Tabelle (hier habe ich schon eigene Pivottabellen ertellt).

Nun möchte ich aber gerne die Daten zum Vergleich z.B. Tabelle 1 = Kalenderwoche 1, Tabelle 2 = Kalenderwoche 2 usw. in eine Pivotchart (hier neues Tabellenblatt) hinzufügen.

Ist das möglich?

Da es sich an eine größere Menge an Daten handelt, möchte ich ungern ein neues Tabellenblatt mit allen Daten hinzufügen.

...zur Frage

Excel Tabelle für jeden Tag im Monat

Hallo,

ich suche und suche und finde nichts ! Ich habe folgenes problem ich muss jeden Tag eine Excel Tabelle ausfühlen mit jeweiligen Datum. Jetzt ist es so da es meinen kollegen zu anstrengend ist jedes mal das datum einzusetzen soll ich für denn ganzen monat die Tabelle mit Datum schon erstellen damit sie nur noch ausfühllen müssen. bisheriges vorgehen datum ädern , speichern als, datum ändern usw geht das nicht irgendwie das er es automatisch speichert mit zb 1.1.2013 als datei 1.1.2013 und weiter 2.1.2013 als daitei 2.1.2013

...zur Frage

Fixe Tage Excel Zahlen flexible Jahr?

Guten Tag,

ich habe eine Tabelle in der Termine von einem Kunden stehen. Dieser hat jeden Monat 2 Termine kostenlos und flexibel 5 Termine im Jahr kostenlos.

Ich möchte, dass mir hinter jedem Datum angezeigt wird wenn die freien Termine aufgebraucht sind.

Z. B.

Januar 3 Termine: 2 fixe und 1 flexibler. 3 Termine frei.

Februar 6 Termine: 2 fixe 4 flexible 6 Termine frei.

März 3 Termine: 2 fixe und 1 kostenpflichtiger.

Da im Januar und Februar die flexiblen Termine aufgebraucht wurden.

MfG

...zur Frage

Lohn am freitag?

Halloo. Normalerweise erhalte ich den Lohn am 25. und daswäre ja ein sonnatg diesen monat. kann es sein, dass ich ihn deshalb schon heute kriege oder erst am montag?

...zur Frage

Was möchtest Du wissen?