kali linux upgrade zerschossen?

...komplette Frage anzeigen

3 Antworten

Folgene befehle funktionieren auch nicht:

apt -f install, apt upgrade, apt dist-upgrade, apt autoremove, dpkg --purge libc6-dev, und viele andere befehle von "dpkg --purge [name]"

Und wie sieht es damit aus? :

apt-get purge gcc-6-multilib
apt-get purge libc6-dev-x32
Antwort bewerten Vielen Dank für Deine Bewertung
Maltedeemann 15.07.2017, 21:30

Da kommt leider die gleiche fehlermeldung. nur der name ist verschwunden :c

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
gcc-6-multilib : Hängt ab von: libc6-dev-i386 (>= 2.11) soll aber nicht installiert werden
Hängt ab von: libc6-dev-x32 (>= 2.11) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

0
Maltedeemann 15.07.2017, 21:32

Ich habe auch leider keine ahnung, wie der Fehler aufgetreten ist. vielleicht irgndwas mit steam?

0
Maltedeemann 15.07.2017, 21:42
@tavkomann

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gcc-multilib:
gcc-multilib hängt ab von gcc-6-multilib (>= 6.3.0-9~); aber:
Paket gcc-6-multilib ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes gcc-multilib (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
gcc-multilib

0
tavkomann 15.07.2017, 21:43
@Maltedeemann
mv /var/cache/apt/archives/libc6-dev-i386_2.24-12_amd64.deb /tmp

Danach

sudo apt-get autoremove && sudo apt-get autoclean

und

sudo apt-get update && sudo apt-get dist-upgrade
1
Maltedeemann 15.07.2017, 21:47
@tavkomann

Erstmal vielen dank für deine hilfe.

Aber bei...

sudo apt-get autoremove && sudo apt-get autoclean

kommt wieder das...:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
gcc-6-multilib : Hängt ab von: libc6-dev-i386 (>= 2.11) ist aber nicht installiert
libc6-dev-x32 : Hängt ab von: libc6-dev-i386 (= 2.24-12) ist aber nicht installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
0
tavkomann 15.07.2017, 21:48
@Maltedeemann

Kannst du denn dieses libc6-dev-i386 installieren (siehe EDVTechTips' Antwort) oder geht das auch nicht?

1
Maltedeemann 15.07.2017, 21:50
@tavkomann

leider nicht. Ich kann überhaubt nichts mehr installieren. Kann man sonst irgendwie kali wieder zurücksetzen?

0
tavkomann 15.07.2017, 21:50
@Maltedeemann
mv /var/cache/apt/archives/libc6-dev-i386_2.24-12_amd64.deb /tmp

Hast du das denn ausgeführt?

Geht manuell installieren auch nicht?

1

Und, wie sieht deine /etc/apt/sources.list bzw. sources.list.d aus?

Antwort bewerten Vielen Dank für Deine Bewertung

apt install libc6-dev-i386

Steht doch da dass diese Paket fehlt, aber andere eine Abhängigkeit davon haben. Wenn das nicht funktioniert probiers manuell zu installieren: https://packages.debian.org/de/wheezy/amd64/libc6-dev-i386/download

Antwort bewerten Vielen Dank für Deine Bewertung
Maltedeemann 15.07.2017, 21:48

Beim versuch irgndwas zu installieren kommt das:

dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libc6-dev-i386_2.24-12_amd64.deb (--unpack):
Versuch, »/usr/include/bits« zu überschreiben, welches auch in Paket libc6-dev-amd64:i386 2.24-12 ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/libc6-dev-i386_2.24-12_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

0

Was möchtest Du wissen?