.jar-Datei mit Java-8 öffnen (Linux, Debian, Java7/8, vServer, Minecraft, Server)?

3 Antworten

Du müsstest

openjdk-8-jre

installieren.

werde ich morgen ausprobieren

0

Eventuell zusätzlich auch openjdk-7-jre deinstallieren.

0

ehm, ok

0

Falls du nicht weiterkommst, kannst du mir gerne deinen Skypenamen geben, dann schau ich mir das mal an, ich arbeite mit Linux-Servern

Kannst ja wenn du java 7 eh nichtmehr brauchst (hast ja java8) die version deinstallieren (y)

jo mach ich mal

0

Ich kann nicht auf dem vserver java 8 installieren?

Das ist der error wenn ich pat-get install oracle-java8-installer eingebe:

Download done. Removing outdated cached downloads... sha256sum mismatch jdk-8u131-linux-x64.tar.gz Oracle JDK 8 is NOT installed. dpkg: Fehler beim Bearbeiten von oracle-java8-installer (--configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück Fehler traten auf beim Bearbeiten von: oracle-java8-installer E: Sub-process /usr/bin/dpkg returned an error code (1) root@c01b06-2:~# java -version java version "1.7.0_121" OpenJDK Runtime Environment (IcedTea 2.6.8) (7u121-2.6.8-2~deb7u1) OpenJDK 64-Bit Server VM (build 24.121-b00, mixed mode)

...zur Frage

Minecraft-Plugins: Java SE Development Kit (JDK) funktioniert nach Installation nicht?

Ich bin gerade dabei, mir JavaScript-Programmierung, genauer Minecraft-Plugins, anzueignen. Und dafür brauche ich schließlich das JDK und Java normal. Wenn ich "java -version" in die Kommandozeile (BusyBox) gebe, wird die Java 64-Bit 8.x, die ich habe, ganz normal angezeigt. Ist halt meine normale Java-Datei, über die auch Minecraft immer gelauncht wird. Allerdings habe ich mir auch das neuste Java Development Kit (64-Bit 8.x)  heruntergeladen und installiert. Der jdk-Ordner existiert mit allen benötigten Dateien bei ProgramFiles (x86)/java/, allerdings spuckt mir die Kommandozeile nach "javac -version" oder eben javac dateiname.java" immer aus, dass javac nicht gefunden wurde...

Bitte Hilfe, wenn jemand weiß, was ich falsch mache. LG

...zur Frage

Ubuntu: sudo apt-get upgrade , schlägt Fehl?

Ich hab heute einfach mal wieder in der Konsole meine Updates und Upgrades laufen lassen wollen. Nach dem ich "sudo apt-get upgrade" eingegeben hab schlug es fehl und mir ist nicht ganz klar wieso. (Habe Ubuntu 14.04 LTS 3)

Hier mal alles nach der eingabe von "sudo apt-get upgrade":

fabian@fabian-MS-7373:~$ sudo apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 openjdk-7-jre : Hängt ab von: openjdk-7-jre-headless (= 7u85-2.6.1-5ubuntu0.14.04.1) aber 7u79-2.5.6-0ubuntu1.14.04.1 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.

Und nun wenn ich den empfohlenen befehl "sudo apt-get -f install" mache oder "sudo apt-get -f upgrade" oder "sudo apt-get upgrade -f" kommt das :

fabian@fabian-MS-7373:~$ sudo apt-get upgrade -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  openjdk-7-jre-headless
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 41,4 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 92,2 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] 
(Lese Datenbank ... 323943 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../openjdk-7-jre-headless_7u85-2.6.1-5ubuntu0.14.04.1_i386.deb ...
Entpacken von openjdk-7-jre-headless:i386 (7u85-2.6.1-5ubuntu0.14.04.1) über (7u79-2.5.6-0ubuntu1.14.04.1) ...
dpkg-deb (Unterprozess): Archiv-Element wird dekomprimiert: lzma-Fehler: komprimierte Daten sind beschädigt
dpkg-deb: Fehler: Unterprozess <Dekompression> gab den Fehlerwert 2 zurück
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/openjdk-7-jre-headless_7u85-2.6.1-5ubuntu0.14.04.1_i386.deb (--unpack):
 Extrahierte Daten für »./usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/client/libjvm.so« können nicht nach »/usr/lib/jvm/java-7-openjdk-i386/jre/lib/i386/client/libjvm.so.dpkg-new« kopiert werden: Unerwartetes Ende der Datei oder des Datenstroms
E: Sub-process /usr/bin/dpkg returned an error code (1)
fabian@fabian-MS-7373:~$ 

Bitte um Hilfe!

...zur Frage

Minecraft Forge startet nicht mit Java 8, Java 7 ist nicht mehr zum Download verfügbar. Kann mir jemand helfen?

...zur Frage

Minecraft Forge 1.7.10 funktioniert weder mit Java 7 noch mit 8?

Mein minecraft Forge 1.7.10 funktioniert nicht. Wenn ich es mit Java 8 probiere kommt wieder der launcher (angeblich weil forge kein java 8 verträgt) , wenn ich es mit java 7 sagt minecraft mir, es geht nur mit java 8...

...zur Frage

Was möchtest Du wissen?