Wie kann ich in einer Excel-Adressliste Dublette und Original löschen?

...komplette Frage anzeigen

3 Antworten

Markiere doch vorher die zu löschenden Zeilen in einer Extra-Spalte und führe darauf einen Filter aus:

=ZÄHLENWENN(A:A;A1)>1
Antwort bewerten Vielen Dank für Deine Bewertung
nadidom 15.12.2015, 11:37

Da die Excel-Liste über 10.000 Adresszeilen lang ist, kann ich die zu löschenden Zeilen nicht händisch markieren. Excel müsste für mich die doppelten Werte selbst erkennen und löschen.

0
Suboptimierer 15.12.2015, 11:44
@nadidom

Du musst die Formel nur in einer Zelle eingeben (der obersten).

Drücke dann: 

  • Strg + c
  • Strg + g → Inhalte... → letzte Zelle → OK
  • Strg + Shift + ↑
  • Strg + v
2

Dafür gibt es keine Funktion oder Formel, müsste mittels VBA programmiert werden

Antwort bewerten Vielen Dank für Deine Bewertung
Iamiam 15.12.2015, 12:56

aber mit fümpf Aktionen ist es erledigt: viieel kürzer als ein Makro schreiben!

  1. obige Formel schreiben
  2. über alle Zeilen kopieren
  3. Formelspalte zu Wert umsetzen
  4. danach sortieren
  5. alle 2en gesammelt löschen
0

Wieso soll das Original auch gelöscht werden? Dann gibt es doch gar keinen Alex Meier mehr....  Kannst du das Anwendungsgebiet ein wenig mehr erläutern?

Antwort bewerten Vielen Dank für Deine Bewertung
nadidom 15.12.2015, 11:35

Genau so ist das auch gemeint. Es soll also keinen Alex Meier mehr geben in der Liste. Hintergrund ist folgender: Ich habe eine Adressliste und eine "Negativ-Adressliste" in eine Excel-Liste zusammengeführt. Die Personen, die in der "Negativ-Adressliste" auftauchen, sollen keinen Brief erhalten. Deshalb muss also Alex Meier komplett entfernt werden, weil er in der Negativliste auftaucht und auch in der Adressliste, deshalb gab es ja die Dublette. Ich hoffe, ich konnte das verständlich formulieren?!

0
pugggi 15.12.2015, 11:58
@nadidom

Ah ok.

Also du kannst neben die Tabelle eine Hilfsspalte setzen und da die Formel laufen lassen:

(A= Vorname, B= Nachname; Bereich bei mir 2-100 muss auf deine Tabelle angepasst werden, je nachdem wie viele Zeilen du hast)

=WENN(ZÄHLENWENNS($A$2:$A$100;A2;$B$2:$B$100;B2)>1;"x";"")

Anschließend kannst du die Spalte filtern und nur x anzeigen lassen. Die kannst du dann löschen.

Es gibt auch die Möglichkeit da ein Makro für zu schreiben aber mit der Formel wird es auch schon gehen. Sonst sag Bescheid dann bastel ich dir was.

1
nadidom 15.12.2015, 12:32
@pugggi

Vielen Dank! Ich werde versuchen, die Formel anzuwenden und gebe morgen Bescheid.

0

Was möchtest Du wissen?