In der Zelle B2 soll "10%" automatisch eingetragen werden, wenn in A1 die Zahlen 26,27,28,29,30 eingetragen werden (mit Hilfe der WENN-Funktion. Wie geht das?

... komplette Frage anzeigen

5 Antworten

=WENN(UND(A1>=26;A1<=30);"10%";0)

bzw. statt "10%" kannst du auch 0,1 reinschreiben und in der Zelle B2 die Formatierung auf "Prozentzahl" stellen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von FireSire
08.03.2016, 14:32

Wollt ich ihm auch erst raten, aber in dem Fall sind auch alle reellen Zahlen zwischen 26 und 31 drin und die wollt er ja eventuell nicht ^^

0
=10%*(GANZZAHL(A1)=A1)*(A1>=26)*(A1<=30)

Als WENN-Funktion:

=WENN(UND(GANZZAHL(A1)=A1;A1>=26;A1<=30);10%;0%)
Antwort bewerten Vielen Dank für Deine Bewertung

Welchen Programm nutzt du?

Mit Excel (oder ähnichen Programmen) funktioniert es mit verschachteten WENN-Funktionen. Also diesen Code weiter fortführen und in die B2 Zeile eintragen. Wichtige auf Klammersetzung achten. Ist leider recht aufwendig, gibt bestimmt bessere Lösungsansätze

=WENN(A2=26;WENN(A3=27;WENN(A4=28;0,1)))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von nothing1990
08.03.2016, 13:33

Ich nutze Excel 2016

0

Klassisch mit einer ODER Bedingung in der Wenn-Formel:

=WENN(ODER(A1=26;A1=27;A1=28;A1=29;A1=30;A1=31);"10%";"")

oder um den Ansatz daCypher aufzugreifen die lückenlose Zahlenkette nutzen:

=WENN(UND(A1>=26;A1<=31;REST(A1;1)=0);"10%";"")

Mit Rest A1/1 = 0 soll geprüft werden, dass es eine ganze Zahl ist, denn auch 26,5 wäre ja zwischen 26 und 31

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
08.03.2016, 13:48

s. Beitrag von Suboptimierer: Man kann Deine Frage auf zwei Varianten verstehen: Soll da die Zahl 10% stehen oder willst Du das Ergebnis von A1 * 10 % rechnen? Ich schreib 10%, Suboptimierer rechnet die 10% von A1 wenn es ein Wert 26 bis 31 ist.

0
Kommentar von Suboptimierer
08.03.2016, 13:49

>26 und <31, sonst topp!

0

Ich glaub, das wirtschaftlichste ist ne verschachtelung von If und Or.

Also... =IF(OR(A1=26,A=27, ~),10%,"Fehler")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von nothing1990
08.03.2016, 13:29

Ich habe es gerade ausprobiert, es hat irgendwie nicht funktioniert. "26,A" hinterlegt das Programm grau und meldet es als ungültig...???

0

Was möchtest Du wissen?