In den Zellen a1 bis a10 stehen zB 1,2,3 15,19, 22,31,32,33. Ich möchte nun wissen in wievielen Zahlenblöcken Zahlen hintereinander vorkommen Hier also 2?

... komplette Frage anzeigen

2 Antworten

Welches Programm?
In Excel ließe sich das mit einer Hilfsspalte lösen:
B1: =SUMME(B2:B10) [Hier wird das Ergebnis angezeigt]
B2: =WENN(UND(A2-A1=1;A3-A2<>1);1;0)
und runterkopieren.

Klappt es? Teste mal genau.

P.S.: Ich füge einfach mal Excel zu Deinen Themen hinzu, kann ja nicht schaden, denke ich.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Marcopietro
12.04.2016, 12:27

Hallo Oubyi, danke für deine Lösung funktioniert genau so wie ich es möchte. Schade, dass es eine Hilfspalte braucht, Verwende es in einem alten Makro4. Danke Markus

0

ebenfalls xl, vermutlich auch openOffice & Consorten:

=SUMMENPRODUKT((A2:A10-A1:A9=1)*1)

funktioniert ohne Hilfsspalte

Musst nur drauf achten, dass die beiden Bereiche gleiche Zellzahlen aufweisen.


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Marcopietro
12.04.2016, 12:22

Hallo Lamiam, danke für Deine Lösung. Sie wäre genial ohne Hilfsspalte. Sie zeigt mir aber an wieviele Zahlen hintereinender vorkommen. Ich bräuchte aber als Lösung wieviele Zahlenblöcke eine Reihenfolge hat. Also bei 1,2,3,5,10,11,12,13,45,49,51,52. Zählenblöcke sind 1,2,3 und 10,11,12,13 und 51,52. Das Resultat sollte also hier 3 ergeben. Lösung wird für Ferienwochenbezüge verwendet. Gruss Markus

1

Was möchtest Du wissen?