Ich möchte in excel ein Abfrage-Tool erstellen. Es gibt beliebig viele Daten (Speisen) in Obergruppen. es soll dann mittels ankreuzen funktionieren?

...komplette Frage anzeigen Muster  - (Excel, Funktion)

2 Antworten

Diese Formel in F2 und runterkopieren:

{=WENNFEHLER(INDEX($C$1:$C$22;KKLEINSTE(WENN($D$2:$D$22="x";ZEILE($D$2:$D$22));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?

er gibt mir noch eine Fehlermeldung: #NAME?

0
@AndiMars

Dann musst Du etwas falsch kopiert haben.
Wenn ich die Formel oben kopiere (ohne die { }) und einfüge, funktioniert sie einwandfrei.
#Name bedeutet, dass Excel eine Funktion nicht kennt, bzw mit einem Teil der Funktion "nichts anfangen kann".
Schau mal genau.

1
@Oubyi

Oder hast Du eine sehr alte Excel-Version.
Kann sein, dass die dann WENNFEHLER noch nicht kennt.
Dann lass das mal weg:

={INDEX($C$1:$C$22;KKLEINSTE(WENN($D$2:$D$22="x";ZEILE($D$2:$D$22));ZEILE(A1)))}

Wenn das klappt, dann baue ich Dir eine andere Fehlerbehandlung drumherum.

1
@Oubyi

das hat geklappt, habe jetzt die ausgewählten Werte oben der Reihe nach stehen...in den anderen steht zwar: #ZAHL! - stört aber nicht... Danke

0
@AndiMars

Das bekomme ich auch noch weg, habe ich doch gesagt.
Sieht dann nur etwas monströser aus, ist aber halb so wild.

{=WENN(ISTFEHL(INDEX($C$1:$C$22;KKLEINSTE(WENN($D$2:$D$22="x";ZEILE($D$2:$D$22));ZEILE(A1))));"";(INDEX($C$1:$C$22;KKLEINSTE(WENN($D$2:$D$22="x";ZEILE($D$2:$D$22));ZEILE(A1)))))}

Offensichtlich hast Du dann aber Excel 2003 oder älter.
DAS solltest Du bei weiteren Fragen unbedingt immer erwähnen, da es - wie Du gesehen hast - in den aktuellen Excel-Versionen einige Funktionen gibt, die es vorher nicht gab oder die sich geändert haben.

1
@Oubyi

Vielen Dank, TOPP... wenn ich die Datei dann in einer neueren Version öffnen, bleiben diese alten "monströsen" Funktionen aber nutzbar... neuere liest ältere?!

0

Mir ist nicht ganz klar, was Du tun willst. Was soll das Ergebnis sein?

Eventuell kommst Du mit Zählenwenn() dazu oder mit einer Pivottabelle.

ich möchte in der anderen Tabelle nur die Daten sehen, welche ausgewählt wurden. Keine Leerzeilen o.ä. sondern nur die ausgewählten Zellen

0

Was möchtest Du wissen?