ich möchte in einer langen liste mit namen ein Suchfeld bauen. ich will nicht auf suchen gehen sondern ein eigenes Feld was mir auch die zeile aufmacht.?

... komplette Frage anzeigen

1 Antwort

Wenn es um Spalte A geht und der Suchbereich bspw. Zeile 1 - 100 wären und der Suchbegriff in B1 steht:
=SUMMENPRODUKT((A1:A100=B1)*ZEILE(1:100))

Die Formel liefert die Zeilennummer. Wenn es um eine andere Spalte geht bzw. mehr als 100 Zeilen sind, musst Du sie entsprechend anpassen.

Der zweite Teil der Frage ist mir unklar: Was heißt Zeile aufmachen? Dort hinspringen oder sind Zeilen ausgeblendet?

Hinspringen würde so gehen:
=HYPERLINK("#A"&SUMMENPRODUKT((A1:A100=B1)*ZEILE(1:100)))

-> wieder: Wenn nicht Spalte A bzw. Suchbegriff in B1, dann noch anzupassen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
15.01.2016, 19:23

DH!

Zeile aufmachen:

vermutlich will er/sie die Zeile darstellen. zB mittels =indirekt(Adresse($B$1;Spalte())  (um mal eine andere Variante zu nennen)

mit dieser Formel die Zellen einer leeren Zeile, zB Zeile 2,  füllen. Dann aber Summenprodukt mit A3:A100 sowie zeile 3:100 oder Spalte A aussparen.

0

Was möchtest Du wissen?