Ich möchte im Excel Zufallszahlen haben, die aber nur bestimmte Werte haben z.Bsp. 13 15 20 30 40 50 60. Ich kann also keinen Zufallsbereich angeben. Wer weiss?

3 Antworten

Du kannst mit der Funktion WAHL eine Abbildungsvorschrift erstellen.

=WAHL(ZUFALLSBEREICH(1;5);4;25;36;48;28)

Wenn sich die Zuordnungsvorschrift formalisieren lässt (wie in deinem ersten Beispiel), reicht:

=ZUFALLSBEREICH(1;10)*10


Schreibe alle Zahlen, die in Frage kommen können, untereinander auf, z.B. in den Bereich A1:A20

Um aus diesen 20 Zahlen eine zufällig auszuwählen verwendest du folgende Formel:

=INDEX($A$1:$A$20;ZUFALLSZAHL()*20+1;1)

Zehnerzahlen wären einfach.  Einfach in einem anderen feld eine Addition (+10) auf Grundlage der Zufallszahl machen.

Excel: Mit SVerweis nicht nur die Werte, sondern auch die Hintergrundfarben auslesen?

Hallo Excel-Profis!

Meine grundsätzliche Frage: Kann man per SVerweis - oder auf andere Weise - auch Hintergrundfarben übertragen?


Zunächst einmal der Aufbau der Seite - falls notwendig.

In Tabelle1 befindet sich eine Liste von A1 bis B44.

Tabelle1/Spalte A enthält Zahlen zwischen 1 und 44, ohne doppelte, nicht auf-/absteigend, sondern durcheinander, und darf auch nicht sortiert werden.

Tabelle1/Spalte B enthält Text, der teilweise farblich hinterlegt ist (insgesamt 9 Farben oder keine Hintergrundfarbe).

In Tabelle2 habe ich in Spalten A1 - A44 Zufallszahlen generiert, die >0 aber <1 sind.

=ZUFALLSZAHL() =>runterkopiert bis A44

Entsprechend der Zufallszahlen habe ich in Spalte B1 bis B44 Zahlen generiert, die im Zahlenbereich 1-44 jeweils nur einmal vorkommen.

=RANG.GLEICH($A1;$A$1:$A$44) =>runterkopiert bis B44

In Tabelle2/SpalteC habe ich diese generierte Zahl aus Tabelle2/SpalteB per SVerweis in Tabelle1/SpalteA gesucht und mit den Wert aus Tabelle1/SpalteB ausgeben lassen.


=SVERWEIS(B1;Tabelle1!$A$1:$B$44;2) =>runterkopiert bis C44

Soweit funktioniert das gut, allerdings hätte ich gerne die farbliche Hinterlegung der Zellen aus Tabelle1/SpalteB ebenfalls übertragen.

Wer kann mir helfen?

Geht das überhaupt und geht das idealerweise auch ohne VBA?

Vielleicht mit einer Hilfsspalte?

Vielen Dank für hilfreiche Antworten! Anita

...zur Frage

Was möchtest Du wissen?