Ich möchte eine Spalte zusammenzahlen. und zwar stehen nur Buchstaben drin. jede Zelle die einen Buchstaben enthält soll zusammen gezählt werden. Wie mache ich?

...komplette Frage anzeigen

4 Antworten

Hallo,

=Zählenwenn(A:A;"*")

zählt die Zellen, die Text enthalten. Obacht, wenn der Inhalt z.B.: "22222a222" ist, ist das für Excel Text, genauso wie wenn der Inhalt ein Leerzeichen ist.

LG, Chris

Edit: Bereich A:A muss natürlich an deine Tabelle angepasst werden.

Antwort bewerten Vielen Dank für Deine Bewertung

Das geht mit einer Hilfsspalte.

Werte sind z.B. in Spalte B, B1 bis B100. Dann in Zelle C1 (es kann auch eine andere Spalte genommen werden) folgende Formel eintragen: =WENN(LÄNGE(B1)=1;1;0)

Diese Formel dann in alle anderen Zeilen der Spalte C kopieren, bei denen die Länge des Eintrags in Spalte B bestimmt werden soll. Hat das Wort in Spalte B die Länge 1 steht in Spalte 1, wenn nicht 0.

Zuletzt mit =Summe(C1..C100) bei 100 Einträgen in Spalte C die Einsen addieren, und schon hat man die Anzahl der Einträge von Spalte B mit der Länge 1. Sind auch Nichtbuchstaben in Spalte B, so muss eine zusätzliche Bedingung ergänzt werden:

=WENN(LÄNGE(B1)=1;WENN(CODE(B1)>=65;1;0);0)






Antwort bewerten Vielen Dank für Deine Bewertung

Heißt das, die anderen Zellen sind leer? Dann:

=ANZAHL2(B:B)

oder stehen in den anderen Zellen Zahlen? Dann:

=ANZAHL2(B:B)-ANZAHL(B:B)

Oder...?

Antwort bewerten Vielen Dank für Deine Bewertung

Für das Feld in dem alle Buchstaben angezeigt werden sollen : =(Bezeichnugdes ersten Feldes, 'A1' zb) & ('B1') & ...

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?