Ich kann keine pgp nachricht der Version "GnuPG v2.0.14 (GNU/Linux)" entschlüsseln!?

... komplette Frage anzeigen

1 Antwort

Bei solchen Problemen halte zwei Dinge für möglich:


1. Bist Du Dir sicher, dass Du den passenden Private Key zu dem Public Key besitzt, die der GnuPG 2.0.14 User einsetzt? Die meisten derartigen Probleme liegen daran, dass der Verschlüsselnde den falschen (oder alten) Public Key einsetzt.


2. Die eher unwahrscheinliche Möglichkeit wäre, dass Inkompatibilitäten zwischen den beiden OpenPGP Implementierungen gibt. Unter der Haube von OpenPGP "verstecken" sich nämlich Dutzende von Varianten, was Verschlüsselungsarten, Schlüssellängen anbelangt.


Um beides zu prüfen, würde ich empfehlen, eine der problematischen Nachrichten mit GnuPG (am Besten auch 2.0.x) zu untersuchen

gpg2 --list-packets  nachricht.txt

Dann bekommst Du infos über die enthaltenen Daten und den verwendeten Schlüsseln.


Auf welcher Plattform (Betriebssystem) möchtest Du entschlüsseln? Vielleicht kann ich Dir ja noch Tools empfehlen?

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?