Ich habe mal eine Excelfrage. Ich muss für meine Arbeit neuerdings eine Art Stundenzettel führen.

...komplette Frage anzeigen

6 Antworten

Eigentlich machst Du da nichts falsch. Excel kann nur nicht mit negativen Zeiten rechnen.
Man kann das zwar ändern, indem man auf das 1904-Datumsformat wechselt, aber das wird allgemein NICHT empfohlen, da es zu anderen Problemen führt.
Zur Lösung Deines Problems:
Zuerst solltest Du das Format der Zellen von hh:mm auf [hh]:mm ändern! Ersteres ist Uhrzeit und letzteres ist wirklich ZEIT. Beim ersten Format würdest Du Dich wundern, sobald Du über 24 h kommst, denn bei z.B. 25 h würde es Dir nur 1 h (sprich 1 Uhr) anzeigen.
Jetzt schau Dir mal meinen Screenshot an (ist nur auf die Schnelle "zusammengestrickt"):
In Spalte A die Soll-Zeiten, in Spalte B die Ist-Zeiten, in Spalte C nur das Vorzeichen (Überschrift kannst Du da natürlich weglassen), und in Spalte D die ABSOLUTEN Differenzen, also immer nur positive Zeiten, die Excel "versteht".
Dazu steht in
C2: =WENN(B2="";"";WENN(A2>B2;"-";"+"))
und in
D2: =WENN(B2="";"";ABS(A2-B2))
Beides bitte bis C10/ D10 runterkopieren (kannst Du in DEINER richtigen Liste natürlich nach unten verschieben, sprich verlängern)
In Zeile 12 werden die Summen berechnet:
A12: =SUMME(A2:A10)
B12: =SUMME(B2:B10)
Und in C12 und D12 die gleichen Formeln wie im Bereich C2:D10:
C12: =WENN(B12="";"";WENN(A12>B12;"-";"+"))
D12: =WENN(B12="";"";ABS(A12-B12))
Du musst nur beachten, wenn Du mit den Summen weiter rechnen willst, dass der Wert in D12 immer positiv ist auch wenn es MINUS-Zeiten sind:
Das ist EINE Möglichkeit von Vielen, dieses Problem zu lösen.
Kommst Du damit klar?

Screenshot - (PC, Excel)
Oubyi 04.12.2011, 20:17

Scheint geklappt zu haben. Das freut mich ☼
Danke fürs ☆

0
Szelina 04.12.2011, 22:24
@Oubyi

Vielen Dank! Es hat soweit sehr gut geklappt,auch wenn ich die Formeln nicht verstanden habe ;)habe sie einfach kopiert ! Kannst du mir noch eine spalte zeigen in der ich die Gutstunden/Minusstunden vom Vormonat mit berechnen kann. Das alles fortlaufend ist! das wäre nett von dir :)

0
Oubyi 05.12.2011, 16:51
@Szelina

Mache ich (Danke fürs Kompliment (:o) ).
Ich schreibe dazu eine neue Antwort, da ich in einen Kommentar keine Screenshots einfügen kann (LEIDER!).

0

Neue Antwort wegen Screenshots:
Also DAS würde ich so lösen (Leider werden die Formeln dabei NOCH etwas komplizierter, aber wenn Du das mit kopieren und anpassen hinbekommst, reicht es ja):
Ich gehe davon aus, dass Du für jeden Monat ein eigenes Tabellenblatt anlegst, und dass das Tabellenblatt für den Monat Januar auch "Januar" heißt, und das für den Februar dann "Februar".
Tabellenblatt Januar sähe in meiner Version so aus (Siehe Screenshot):
In C13 steht hier einfach =C12
und in D13 steht = D12
DAS gilt aber natürlich nur für den Januar.
Im Februar (siehe Screenshot beziehe ich mich dann auf die Jahressumme aus dem Januarblatt, und addiere dazu die Summe des Februarblattes (C12 und D12): Formel in C13:

=WENN((WENN(Januar!C13="-";-1;1)*Januar!D13 + WENN(C12="-";-1;1)*D12)<0;"-";"+") `

Formel in D13:

=ABS(WENN(Januar!C13="-";-1;1)*Januar!D13+WENN(C12="-";-1;1)*D12)

Im nächsten Monat, musst Du nur das Januar! durch Februar! ersetzen, sodass im März, die Monatssumme März zur Jahressumme im Februar addiert wird. Und so weiter.
Kommst Du damit klar?
Wenn Du willst, kann ich Dir die Formeln auch ein bisschen erklären, aber das MUSS nicht sein, weil es evtl. zu sehr verwirrt. Frage dann am besten nochmal gezielt nach.

Tabelle:   Januar - (PC, Excel) Tabelle:   Februar - (PC, Excel)
Szelina 07.12.2011, 09:14

Danke,das hat soweit auch gut geklappt.mein Dienstplan geht immer 4 Wochen vom 21 Novemb. bis 18. Dez. u.s.w.! ich habe für jeden dienstplan eine neue Tabelle angelegt(Unten bei Exel steht Tabelle 1,2,3 die meine ich)ich habe dann statt den Monaten einfach in die Formel Tabelle 1 eingegeben um die Gutstunden vom Vormonat mit in den nächsten Dienstplan zu bekommen. aber was mache ich nach 3 Monaten,denn exel hat ja nur 3 Tabellenspalten unten stehen?

Und dann würde ich noch gern rechts eine Spalte erstellen.In dieser würde ich gern an jedem Tag sofort sehen wie der Aktuelle Stand meiner Gut/Minusstunden bis zu diesem Tag ist (plus alle vom vorMonat natürlich),ich hoffe das war verstendlich.Kannst du mir da auch nochmal helfen.

Du hast mir dabei schon sehr geholfen,ich habe sogar schon einen Fehler entdeckt,mein Betrieb hat sich schon verrechnet gehabt und mir mehrere Stunden zu viel abgezogen.Durch deine Tabbelle habe ich einen sehr guten Überblick,da ich Teilzeitkraft (3/4 Stelle) bin und stendig unterschiedliche Stunden habe. Vielen Dank

0
Oubyi 07.12.2011, 21:11
@Szelina

Erstmal zu der vierten Tabelle:
Rechts neben Tabelle 3 ist noch so ein ganz kleiner "Reiter", wenn Du da drauf klickst, wird immer eine neue Tabelle eingefügt. Falls Du eine alte Excel Version hast (bin mir nicht sicher, ob es den da schon gab), mache einen Rechtsklick auf den Tabellenreiter und dann:
Einfügen / Tabellenblatt.
Übrigens, mit einem Doppelklick auf den Reiter, kannst Du Deine Tabellen auch umbenennen. Wegen der Spalte mit den kumulierten Werten, überlege ich mir morgen noch mal was.

0
Oubyi 08.12.2011, 20:34
@Oubyi

Für die Erweiterung muss ich wieder neu antworten, wg. Screenshot.

0

Zweite neue Antwort wg. Screenshot:
Ich habe jetzt mal die Tabelle Februar erweitert. Ich hoffe ich habe Dich richtig verstanden (siehe Screenshot):
Ist jetzt noch etwas komplizierter, aber eigentlich! ganz einfach:

Diese Formel in E2:
=WENN(WENN(Januar!C13="-";-1;1)*Januar!D13+(WENN(C2="-";-1;1)*D2)<0;"-";"+")

Diese Formel in F2:
=ABS(WENN(Januar!C13="-";-1;1)*Januar!D13+(WENN(C2="-";-1;1)*D2))

Diese beiden Formeln (oben) sind "einmalig", das der Wert vom Vormonat (musst Du anpassen) übernommen werden muss.
Die Formeln in E3 / F3 kannst Du dann wieder runterkopieren:

Formel in E3:
=WENN((WENN(C3="-";-1;1)*D3+WENN(E2="-";-1;1)*F2)<0;"-";"+")

Formel in F3:
=ABS(WENN(C3="-";-1;1)*D3+WENN(E2="-";-1;1)*F2)

Im Monat Januar muss ja nichts übernommen werden, das schreibst Du einfach in:
E2: = C2 und in
F2: = D2

Ich hoffe das "haut so hin".
Teste auf jeden Fall mal ausführlich, dazu habe ich jetzt keine Lust mehr.

Tabelle Februar - (PC, Excel)
Szelina 11.12.2011, 14:01

Vielen lieben Dank für deine Mühe,schöne Weihnachten und liebe Grüße

0

ist doch klar, weil es keine negative zeit in diesem sinne gibt. z.b. wirst du ja nie sagen: es ist -15.10uhr; und die formatierung die du gewählt hast, ist für uhrzeiten und nicht für zwecke die du verfolgst. Mein tipp: Formatierung als Zahl und dann in Minuten und machst dir automatisch, dass alle Zahlen durch 60 dividiert werden, dann hast du deine Stunden und das geht auch ins negative (; hoffe konnte helfen

prüfe mal bei den Minusstunden das** Format** der Zelle,vielleicht mußt du Minus-Zahlen zulassen

Was möchtest Du wissen?