ich habe ein WENN wert und möchte da noch eine obergrenze rein machen von 100 km ?

...komplette Frage anzeigen

4 Antworten

Die Frage ist etwas kompliziert zu verstehen. Wenn ich es richtig kapiert habe, bekommst Du die Werte aufaddiert bezahlt.

Ich würde das ehrlich gesagt nicht in eine einzige Formel packen, wenn Du nicht richtig gut mit Excel vertraut bist, sonst ist sehr schwierig Fehler zu finden bzw. noch etwas anzupassen.

Du könntest Du eine kleine Tabelle aufbauen. Wenn die Kilometerzahl in A1 steht, schreibst Du in A2 - A5 die Beschriftung 1 - 7; 7-50, 50-100, 100+
und in Spalte B die Formeln:

B2 =WENN(A1<=7;A1;7)*2
B3 =WENN(A1>=8;WENN(A1<=50;A1-7;43);0)*1,5
B4 =WENN(A1>=51;WENN(A1<=100;A1-50;50);0)*1,4
B5 =WENN(A1>=101;A1-100;0)*1,32
B6 =SUMME(B2:B5)

Das greift aber nur für ganze Kilometer, generell musst Du noch mal schauen oder erläutern, wie die Grenzen genau sind mit > bzw. >=


perfekt das ist die Lösung von meinem Problem. Ich habe da leider etwas komplizierter gedacht. Aber so ist es genau perfekt.

0
@Eibingerbub

Schau dir aber auch mal die Variante von antitroll an. Wenn man die Berechnungen fest hinterlegt (wäre ok wenn es sich nicht oft ändert)  geht es doch übersichtlich in einer Formel 

Unter dem Strich nur

0

Deine Staffelung ist für nicht 100%ig transparent, aber ich ordne das Problem einem häufig auftretenden Typus zu.

Du musst entweder von unten nach oben mit < prüfen oder von oben mit >.

Beispiel:

=WENN(A1<=7;14;WENN(A1<=50;64,5;...
=WENN(A1>100;66;WENN(A1>50;70;...

Du kannst anstelle WENNs dir auch eine Tabelle erstellen und darauf mit SVERWEIS zugreifen.

Könntest du mal die Formel posten die du bis jetzt dafür erstellt hast?

Bei deiner Aufstellung mußt du dich entscheiden: bis 50 km oder ab 50 km
Bei der Eingabe von 50 wäre ja nicht klar ob der Multiplikator 1,50 oder 1,40 ist.

Das gleiche Problem ist auch bei 100 km.

Das Problem in deiner Frage ist, das bei 150 km die Möglichkeiten 50 km und 100 km beide enthalten sind. Welches Ergebnis soll dann angezeigt werden?

Oder meintest du damit das bei 150 km erst nur 50 km gerechnet werden und dann für die restlichen 100 km mit dem Berechnen erneut angefangen werden soll?

Wenn Du die km in z.B. in A1 stehen hast dann mit folgender Formel:

=WENN(A1>100;(A1-100)*1,32+148,5;WENN(A1>50;(A1-50)*1,4+78,5;WENN(A1>7;(A1-7)*1,5+14;A1*2)))

Was möchtest Du wissen?