Ich benötige eine Excel Formel, wenn Mitarbeiter mindestens 60 bis 62 Jahre alt sind, dass mir den Ja angezeigt wird.?

...komplette Frage anzeigen

6 Antworten

Ich verstehe die Frage als: 59=Nein, 60=Ja, 61=Ja, 62=Ja, 63=Nein.

Annahme: du hast das Geburtsdatum und nicht das Alter:

Mein Lösungsvorschlag:

Ohne verschachtelte Abfragen, berechnest du den Abstand von der Zahl 61 (die Mitte zwischen 60 und 62) in einer Formel abhängig von "HEUTE" und der Zelle A1.

Wenn du nicht "Wahr" und "Falsch" haben möchtest, sondern individuell eine Ausgabe "Ja"/"Nein" willst, musst du nur noch Ist der Abstand größer als 1(<60 UND >62) in einer Abfrage überprüfen und das entsprechende Ergebnis ausgeben:

=WENN(ABS(GANZZAHL(BRTEILJAHRE(A1;HEUTE()))-61)<2;"JA";"NEIN")

Vorsicht:

Die DATEDIF-Funktion ist nicht unbedingt korrekt [1]

Constraint:

Das funktioniert natürlich nur, wenn die Zahlen 60-62 fix sind und du sie nicht beliebig entsprechend anderer Zelleninhalte festlegen willst.

[1] https://support.office.com/en-us/article/DATEDIF-function-25dba1a4-2812-480b-84dd-8b32a451b35c

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Funfroc
10.02.2017, 11:12

Die DATEDIF-Problematik ist für diesen Fall aber nicht relevant, da Abfrage nur auf "y" stattfindet. Daher die Formel hier durchaus direkteste Lösung zu betrachten.

1

Guten Morgen,  

Kommt auch bisschen auf den Rest der Tabelle an. 

Die WENN Funktion reicht evtl in Verbindung mit anderen anderen Funktionen oder bedingter Formatierung. 

Wird das Alter denn schon berechnet oder möchtest du Geburtsdatum mit heutigem Datum vergleichen und so das Alter Bestimmen?. 

Es gibt einige Möglichkeiten,  der Zweck der Tabelle ist auch ein Punkt denn ein Ja ist nicht unbedingt notwendig. 

Lg GerSouls 

Antwort bewerten Vielen Dank für Deine Bewertung

Einfach alle Mitarbeiter in Namentlich in der Excel Tabelle aufführen, in die zweite Spalte das Geburtsdatum rein und dann nach Datum Automatisch sortieren. Ab wann der Mitarbeiter 60 oder 62 ist sollte man so eigentlich schnell ohne ja oder nein erkennen.

Antwort bewerten Vielen Dank für Deine Bewertung

Alle Antworten bisher sind ja gut und schön, aber Du wolltest eine Formel:

Angenommen in A1 steht das Geburtsdatum

=WENN(UND(DATEDIF(A1;HEUTE();"y")>59;DATEDIF(A1;HEUTE();"y")<63);"Ja";"Nein")

Gruß aus Berlin.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
10.02.2017, 13:49

DH!

Nur zur Ergänzung. Vor Kurzem habe ich eine schönen Trick gelernt, um festzustellen, ob ein Wert zwischen zwei anderen liegt:

=WENN(MEDIAN(DATEDIF(A1;HEUTE();"y");60;62)=DATEDIF(A1;HEUTE();"y");"Ja";"Nein")

Ist nicht besser, aber imho irgendwie "schön" 

1

Du benötigst die Geburtsjahre der Mitarbeiter und verwendest dann eine "Wenn-dann-Formel".

Also wenn "Zelle mit Geburtsjahr" 1957 dann "Zelle mit Hinweis"Ja"

Antwort bewerten Vielen Dank für Deine Bewertung

Müsste eigentlich über eine Wenn-Dann-Formel zu machen sein.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?