Hilfe zu mehrfach verschachtelter WENN Funktion in Excel 2016?

...komplette Frage anzeigen

4 Antworten

Was direkt Excel auffallen müsste, ist dass du einmal X anstelle A1 geschrieben hast.

Dazu kommt, dass du dir die letzte Abfrage ersparen kannst, weil es keine andere Möglichkeit gibt. Wenn etwas nicht kleiner ist als 0,8... und nicht größer ist als 1,4..., dann muss es dazwischen liegen. → Es reichen zwei WENN-Abfragen.

siehe meine Formel :D

1

Vielen Dank für die Antworten! X=A1 sorry für den Schreibfehler hier im Thread. Pucky99s Formel funktioniert soweit, hab das ganze noch etwas angepasst weil noch ein Fehler in meiner angegebenen Formel war: =WENN(A1<0,8491;0;WENN(A1>1,4702;A1-0,9706;A1-A2)) 

Falls das Ergebnis dieser Formel negativ ist würde ich Excel gerne noch sagen, dass der Wert automatisch auf 0 gesetzt wird, ist so was möglich?

Ja, klammere das Ganze mit MAX(...;0)

1
@mrniggo

Bitteschön!

Allerdings wundert es mich, dass du fragst. Nun ist es doppelt gemoppelt, denn A1<0,8491 müsste die negativen Werte bereits berücksichtigen und sie auf 0 setzen.

Achso, habe es verstanden. Es geht dir um A1-A2. Das kann negativ sein und das möchtest du abfangen.

1

Public Function Test(A1 As Double, A2 As Double) As Double
     Select Case True
         Case A1 < 0.8491
             Test = 0
         Case A1 > 1.4702
           Test = A1 - 0.9706
         Case (A1 > 0.8491) And (A1 < 1.4702)
             Test = A1 - A2
     End Select
End Function


=WENN(A1<0,8491;0;WENN(A1>1,4702;A1-0,9706;A1-A2))

Probier es mal so


Was möchtest Du wissen?