Hilfe bei fast fertiger Excel-Tabelle

Tabelle - (Excel, Tabelle, Zeiterfassung)

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Wie ist diese Formel für die Soll-Stunden?
=WENN(ODER(A7="Samstag";A7="Sonntag");0;WENN(ODER(C7="";D7="");"";$H$1))
Beim 1. Dann-Wert kannst du statt 0 auch "" schreiben, wie es dir lieber ist. Deine bestehende +/- Formel sollte dann damit klarkommen.

Funktioniert es so?

Hmm, er meckert zumindest nicht über die Formel, wie bei mir immer :-D Aber als Soll-Stunden habe ich immer noch die, die ich an den anderen Tagen auch habe.

0
@DeeDee07

Ja klar. Habe ich. Liegt es vllt. an der Formel für meinen Wochentag? =WENN($B$1="";"";WOCHENTAG(B10))

0
@deufelschen

Ja, daran liegt es wohl. Bei Excel ist Montag=1, Dienstag=2,....,Sonntag=7. Versuch es mal mit dieser Formel:
=WENN(A7>=6;0;WENN(ODER(C7="";D7="");"";$H$1))

1
@DeeDee07

Kleine Korrektur: Standardmäßig ist Sonntag = 1 und Samstag = 7. Deswegen solltest du bei der Wochentagsformel Typ 2 auswählen, also:
=WENN($B$1="";"";WOCHENTAG(B10;2))

1
@DeeDee07

Hmm, wenn ich das mit dem Typ 2 änder, dann stimmen die Wochentage nicht mehr :/

0
@deufelschen

oh, ok. Ich hatte beim Test nur die Zahlen angezeigt, nicht die Tage. Dann nimm deine Wochentags-Formel und wir ändern die Sollstunden-Formel auf:
=WENN(ODER(A7=1;A7=7);0;WENN(ODER(C7="";D7="");"";$H$1))

1
@DeeDee07

AAHHHH ich glaub ich brech ab. ES FUNKTIONIERT. Hab zwar jetzt an dem Wochenenden immer die 0 da stehen, aber ist egal. Dank dir, bist ein Schatz :-)

0

Mir ist deine eigentliche Frage nicht klar Kann du bitte klar schreiben, was genau du ausrechnen willst und wie die Bedingungen lauten.

Was möchtest Du wissen?