Hilfe bei Excel nötig?

...komplette Frage anzeigen

4 Antworten

Der Inhalt einer einzigen Zelle kann ja nicht zwei verschiedene Ausprägungen enthalten, insofern ist klar, dass diese Formel nicht funktioniert bzw. immer das SONST Ergebnis (also yes) liefert. Wenn "married" drin steht, passt das für die 1. UND Bedingung - gleichzeitig ist aber klar, dass es für die 2. UND Bedingung nicht passen kann und andersrum.

edit: Außer Du meinst, wie von lasttobi angedeutet, dass nicht der komplette Inhalt der Zelle verglichen werden soll sondern nur ein Teil enthalten sein muss. Das ginge dann schon mit der gleichen Zelle, ist aber eine ganz andere Abfrage.


Ich untersuche im Moment englische get-Passive.

Daher steht in jeder Zeile der Spalte AS ein englisches Partizip. Jedoch muss ich von diesen Partizipien einige ausschließen, da sie kein wirkliches get-Passiv darstellen, darunter z. B. "married" und "dressed". Es gibt aber eben noch viele andere Partizipien, die auch ausgeschlossen werden müssten. Aus diesem Grund brauche ich eine Spalte, in der mir angezeigt wird, ob das Partizip in der jeweiligen Zeile relevant (=yes) oder nicht relevant (=no) ist.

Bei "married" und "dressed" soll die Funktion also beispielsweise "no" in eine Spalte schreiben.

Bei "caught" soll die Funktion dann "yes" in diese Spalte schreiben.

Ich hoffe, es ist verständlich :) Wenn nicht, einfach nochmal fragen ;)

DeeDee07 21.02.2017, 10:10

Für dein Vorhaben brauchst du nicht die UND-, sondern die ODER-Funktion (mit sonst gleichem Aufbau).

Du willst ja wissen, ob in der Zelle "married" ODER "dressed" steht. Wie Ninombre bereits festgestellt hat, kann ja eine Zelle nicht "married" UND "dressed" (als alleiniger Inhalt) sein.

Wenn es allerdings so viele Ausnahmen geben soll (es bleibt ja nicht bei den beiden), wird das mit WENN(ODER) schnell umständlich und unübersichtlich. Besser wäre eine eigene Liste aller Ausnahmen zu erstellen und dann per SVERWEIS i.V.m. WENN auszugeben.

1
Ninombre 21.02.2017, 17:10

Das erklärt besser, was Du vorhast. Wie deedee schon geschrieben hat, macht es aber keinen Sinn, sämtliche Ausnahmen in der Wenn-Abfrage selbst zu packen. Mach eine Liste (in meinem Beispiel Spalte A1:A100) mit married, dressed & Co.

=WENN(ISTFEHLER(VERWEIS(AS2;A$1:A$100));"yes";"no")

Damit prüfst Du, ob der Begriff aus AS2 in der Liste A1:A100 gefunden wird bzw. wenn nicht, wird ein #NV für nicht-vorhanden ausgegeben, das ist eine Fehlermeldung. Fehler oder nicht Fehler lässt sich dann mit Wenn ganz normal abfragen.

1

Versuch doch bitte mal in Prosa zu beschreiben was die Formel genau tun soll, dann wird es deutlich leichter dir zu helfen als wenn du eine Formel Formel postest, die ohnehin nicht nicht funktionieren kann.

ich glaube folgendes sollte funktionieren:

=WENN(UND(FINDEN("married";AS1153);FINDEN("dressed";AS1153);"no";"yes")

Weis nur nicht wieso du zuerst "no" und dann "yes" in der Funktion hast. Im Moment wird "no" ausgegeben, wenn beide Texte gefunden werden und "yes" wenn nicht beide gefunden werden. Hört sich falsch an, da ich aber deine Intention nicht kenne kann es auch richtig sein ^_^

Lg Tobi

Oubyi 21.02.2017, 02:26

DH!
Gute Interpretation und gute Idee.
Allerdings denke ich, dass man da noch etwas komplizierter aufbauen muss, um einen #WERT-Fehler zu vermeiden. Außerdem fehlt eine Klammer. SO klappt es bei mir:

=WENN(UND(ISTZAHL(FINDEN("married";AS1153));ISTZAHL(FINDEN("dressed";AS1153)));"no";"yes")

0

Was möchtest Du wissen?