Hilfe bei dropdownliste Excel?

2 Antworten

Was du vorhast, ist extrem unsauber!

Der saubere Weg: du hast eine Zelle für die Eingabe (die "5" in deinem Beispiel) und eine weitere Zelle mit der Auswertung, in der du je nach Drop-Down-Listeninhalt diese 5 gegebenenfalls mit -1 multiplizierst.

Den Farbumschlag erreichst du dann entweder über die bedingte Formatierung oder über die Zellenformatierung selbst.

Das Problem ist: Ich habe das so eingerichtet, dass man als beispiel A2-A10 wählt man aus zwischen "Eingetragen" und "Ausgetragen" per drop downliste. B1 C1 D1 steht der Produktname also z.B. wasser cola Fanta und din B2 C2 D2 würde man dann die Zahl eintragen wieviele man ein bzw. ausgetragen hat.

0
@Wisenspecht

ich verstehe das schon - aber dann ist das Konzept falsch.

Was du machen kannst: mit der bedingten Formatiereung kannst du die Umfärbung aufgrund des Drop-Down-Listeninhalts durchführen. Der Zahlenwert würde halt positiv (oder wie du ihn auch immer eingegeben hast) bleiben.

0
@gfntom

Oder (mit mehr Arbeit verbunden)

Der erste Produktname steht in den Zellen B1-C1 (Zellen verbinden), zweiter Produktname steht in D1-E1 (Zellen verbinden), usw.

In B2-Bx gibst du deine Werte ein, in C2-Cx wird das Vorzeichen des Wertes anhand der Drop-Down-Liste automatisch eingetragen

0
@gfntom

Ok dann versuche ich das mal so wie du es als zweites beschrieben hast. Wie wäre dann die Formel damit C2-Cx bei der dropdown Auswahl automatisch negativ wird? Und schonmal vielen Dank für Deine hilfe gfntom

0
@Wisenspecht

In C2:

=WENN(A2="Ausgtragen";-B2;B2)

Oder, wenn nicht sicher ist, dass der Wert in B1 positiv eingetragen wurde:

=WENN(A2="Ausgtragen";-ABS(B2);ABS(B2))

Über die bedingte Formatierung kannst du dann die Zelle rot färben, wenn der Wert in C2 < 0 ist.

0

Ich würde Dir das mal anbieten,

Spalte B:C Eingänge / Ausgänge (Dropdows); C: Erfassen; D: Auswahl (Dropdown).

G:I, die jeweiligen Bestände nach Eingängen - Ausgängen.

Wenn in G:I ein Grenzwert unterschritten ist, kannst Du das per "Bedingte Formatierung" Rot anzeigen lassen.

Woher ich das weiß: eigene Erfahrung
 - (Computer, Excel)

Ok danke dir. Ich probier das mal so.

0

Wie kann ich bei Excel den Inhalt eines Kombinationsfeldes als Zahl formatieren?

Ich habe mehre Kombinationsfelder die aus einer Spalte Zahlen von 1 bis 19 zur Wahl stellen. Die gewählte Zahl wird dann wieder rum in einer Zelle in der Spaöte d angezeigt und von einer Index Formel aufgegriffen/weiterverarbeitet. Das Problem ist das die Zahl welche in Spalte d wiedergegeben wird als Text ercheint obwohl die Zelle als Zahl formatiert ist. Das hat zur Folge das die Berechnung nicht automatisch aktualisiert wird sondern ich jede Formel mit ENTER zum rechnen bringen muss. WIe kann ich das Kombinationsfeld dazu bringen Zahlen und nicht Text weiter zugeben? Ich habe nichts mit VBA Programiert sonder den Bereich der zur Wahl stehenden Zellen einfach in Eigenschaften eingetragen. Diese sind auch als Zahl formatiert.

Vielen dank.

...zur Frage

Was möchtest Du wissen?